Bug 31725 - StringIndexOutOfBoundsException in versioning explorer
StringIndexOutOfBoundsException in versioning explorer
Status: VERIFIED FIXED
Product: obsolete
Classification: Unclassified
Component: vcsgeneric
-S1S-
PC Windows XP
: P3 (vote)
: 3.x
Assigned To: Martin Entlicher
issues@obsolete
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-06 09:38 UTC by Martin Grebac
Modified: 2003-12-11 14:27 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Grebac 2003-03-06 09:38:53 UTC
1. Mount openide src package.
2. Open versioning explorer on file
org.openide.text.CloneableEditorSupport
3. You get following exception:

Annotation: Exception detected in class
org.netbeans.modules.vcs.profiles.cvsprofiles.commands.CvsRevisionListGetter.
java.lang.StringIndexOutOfBoundsException: String
index out of range: -1
	at java.lang.String.substring(String.java:1474)
	at java.lang.String.substring(String.java:1447)
	at
org.netbeans.modules.vcs.profiles.cvsprofiles.commands.CvsRevisionListGetter.addTags(CvsRevisionListGetter.java:259)
	at
org.netbeans.modules.vcs.profiles.cvsprofiles.commands.CvsRevisionListGetter.runLog(CvsRevisionListGetter.java:118)
	at
org.netbeans.modules.vcs.profiles.cvsprofiles.commands.CvsRevisionListGetter.exec(CvsRevisionListGetter.java:148)
	at
org.netbeans.modules.vcscore.cmdline.ExecuteCommand.runClass(ExecuteCommand.java:684)
	at
org.netbeans.modules.vcscore.cmdline.ExecuteCommand.run(ExecuteCommand.java:777)
	at
org.netbeans.modules.vcscore.cmdline.UserCommandSupport.execute(UserCommandSupport.java:312)
	at
org.netbeans.spi.vcs.commands.CommandTaskSupport.execute(CommandTaskSupport.java:74)
	at
org.netbeans.modules.vcscore.cmdline.UserCommandTask.execute(UserCommandTask.java:323)
	at
org.netbeans.api.vcs.commands.CommandTask.runCommandTask(CommandTask.java:100)
	at
org.netbeans.api.vcs.commands.CommandTaskInfoImpl.run(CommandTaskInfoImpl.java:40)
	at
org.netbeans.modules.vcscore.commands.CommandProcessor$5.run(CommandProcessor.java:654)
	at org.openide.util.Task.run(Task.java:136)
	at
org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:328)
[catch] at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:668)
Comment 1 Martin Entlicher 2003-03-06 15:35:54 UTC
The problem is in the fact, that the commit log happens to start with
the word "revision ...". The parser then mistakenly suppose that it is
a new revision.

The parser should take into account also the lines, that delimit
individual revision logs.
Comment 2 Martin Entlicher 2003-03-06 15:36:43 UTC
PS.: this does not happen with org.openide.text.CloneableEditorSupport
but org.openide.text.EditorSupport.
Comment 3 Martin Entlicher 2003-08-05 14:26:52 UTC
Fixed in the main trunk and prj40_prototype branch:

Checking in CvsRevisionListGetter.java;
/cvs/vcsgeneric/profiles/cvsprofiles/src/org/netbeans/modules/vcs/profiles/cvsprofiles/commands/CvsRevisionListGetter.java,v 
<--  CvsRevisionListGetter.java
new revision: 1.2; previous revision: 1.1
done

Checking in CvsRevisionListGetter.java;
/cvs/vcsgeneric/profiles/cvsprofiles/src/org/netbeans/modules/vcs/profiles/cvsprofiles/commands/CvsRevisionListGetter.java,v 
<--  CvsRevisionListGetter.java
new revision: 1.1.18.1; previous revision: 1.1
done
Comment 4 Jiri Kovalsky 2003-10-14 15:33:51 UTC
Perfect, I have simulated the same commit message and opening
versioning explorer didn't throw anything. Verified in development
build #200310130100 of NetBeans 4.0.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo