Bug 31688 - [jdk1.4.0] Focus in the Explorer window has been lost after switching windows
[jdk1.4.0] Focus in the Explorer window has been lost after switching windows
Status: CLOSED WONTFIX
Product: platform
Classification: Unclassified
Component: Window System
3.x
Sun Solaris
: P3 (vote)
: TBD
Assigned To: mslama
issues@platform
: A11Y, FOCUS, JDK_SPECIFIC
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-05 13:40 UTC by ccv
Modified: 2008-12-23 10:36 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ccv 2003-03-05 13:40:50 UTC
1. Select, for example, some folder in the
Explorer window and call Properties window from
context menu. 
2. Focus is in the Propeties window. Push ALT-TAB
key until Explorer is activated.
3. Pushing Down or Up arrow in Explorer does
nothing, focus has been lost.

As workaround I close Explorer via ALT-F4 and open
it again from main menu.

Product Version       = Sun ONE Studio 5, Standard
Edition (Build 030304)
IDE Versioning         = IDE/1 spec=3.42
impl=030304
Operating System   = SunOS version 5.8 running on
sparc
Java; VM; Vendor    = 1.4.0; Java HotSpot(TM)
Client VM 1.4.0-b92; Sun Microsystems Inc.
Comment 1 Marian Mirilovic 2003-03-05 13:57:39 UTC
I am sorry, but I cannot reproduce (strictly speaking I am not
understand):

If you said that invoke properties window by pushing context menu
"Properties", than new separate properties window should be opened,
than you cannot move focus by Tab / Ctrl+Tab to Explorer (it's another
window) !
Comment 2 vgorr 2003-03-05 14:25:26 UTC
Absolutely agree new Property window is other one. But the ALT-TAB key
allows to walk on all existing windows, correct? The issue report
underlines when we will be again in this Property window a focus is
lost. Note also this issue exists ONLY for the SDI mode. All correctly
works for the MDI one. I very hope my explanation will help you.
Comment 3 Marian Mirilovic 2003-03-06 15:56:16 UTC
Thanks for explanation, but I cannot reproduce still. Maybe settings
of your window manager is important: do you use "focus follows mouse" ?
Comment 4 vgorr 2003-03-07 13:59:19 UTC
Unfortunately I don't see me latest comments done today morning
for this issue. Therefore I need to repeat some notes.

Probably I'm clear why you cannot to reproduce this issue.
Firstly there is a small typo in the my previous comment.
The following sentence
	 when we will be again in this Property window
needs to read as
	 when we will be again in this Explorer window.
				       --------
Secondly I would like to note this issue is reproducible
for the jdk1.4.0 but not jdk1.4.1. All works without any issues
for the latest jdk version.
Comment 5 Marian Mirilovic 2003-03-07 15:24:56 UTC
Yes, I havce reproduced it, thanks.

Issue is reproducible only with [jdk1.4.0](x), it isn't reproducible
on [jdk1.4.1](x) neither [jdk1.4.2](bx).

Marek, it seems like if Window(Explorer) is "focused" (active), it has
not focus, focus is still inside property sheet window.
Comment 6 mslama 2003-03-12 13:53:26 UTC
I tested on Linux, current dev build and it works (JDK 1.4.0_02, nb
dev build 030312, SDI). Marian please can you check. Is it specific
only to Solaris? I switch among windows using keyboard Alt-Tab in my
case. Recently as I fixed issue #29848 there was change in
ExplorerTab.requestFocus(). Thanks.
Comment 7 Marian Mirilovic 2003-03-12 14:06:31 UTC
Marek: I can still reproduce it :(
Comment 8 vgorr 2003-03-12 14:32:57 UTC
I would like to say I reproduce this issue on Solrais 
platform with JDK1.4.0 and SDI mode. I use the latest
Nevada build from 2003/02/10. 
Comment 9 mslama 2003-03-14 10:45:54 UTC
As it happens only on Solaris and JDK 1.4.0 I suggest to close this
issue. It looks like it is problem of JDK with transfering focus
between heavyweight components (native windows). It works fine on JDK
1.4.1 so as workaround I suggest to upgrade JDK.

We investigated it with Marian and focus stays in original
(Properties) window. We do not receive FOCUS_GAINED for activated
window (Explorer).
Comment 10 vgorr 2003-03-14 11:01:26 UTC
No problems you can close this issue as 'will not fix'.
Although there is a small objection against this. We need to use
the JDK1.4.0 version to test the S1S5SE. It's requirement of MPK QA
manager. Some tests will be failed due to this issue will not be
fixed. What should we explain in this case? I don't think the
workaraund suggested by you can like all. 
Comment 11 mslama 2003-03-14 11:09:34 UTC
Hmm hmm :). We can ask AWT team. They probably have some issue for it.
I have no idea what could we do with it. We call requestFocus() on our
component when window is activated. Then it is responsibility of AWT
to transfer focus. I will check what we call from NB and ask AWT team
if there is some issue about it.
Comment 12 mslama 2003-03-14 12:27:20 UTC
We found issue in Bugtraq: It is #4504821: "Focus is not regained
sometimes when alt-tabbing between applications." It was fixed in JDK
1.4.1. What should I do with this issue?
Comment 13 vgorr 2003-03-14 12:38:06 UTC
I suppose you need to close this issue. I'll exclude all tests
depending on this one from testing for JDK1.4.0 version.
Thanks for your time.
Comment 14 mslama 2003-03-14 12:41:57 UTC
Ok. Done.
Comment 15 Marian Mirilovic 2003-07-28 16:22:54 UTC
verifying, closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo