Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 31227 - Exception when changing file extension settings
Exception when changing file extension settings
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
3.x
PC Windows ME/2000
: P3 (vote)
: 3.x
Assigned To: rmatous
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-19 16:26 UTC by bljohnson
Modified: 2008-12-22 10:32 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
ide log (22.91 KB, text/plain)
2008-02-12 23:23 UTC, Peter Lam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bljohnson 2003-02-19 16:26:34 UTC
Sorry I cannot seem to reproduce this error on other 
versions of netbeans.  I can on my copy (3.4.1 release) 
however.

1)  I went to options and noticed the telnet server 
option.  I turned it on and connected using win2k telnet.  
I then hit ctrl-] and quit out.  Got a SocketException 
thrown.  This wasnt really a big deal so I ignored it.

2)  I then noticed the Options -> System Settings -> Show 
File Extensions.  Great feature - so I set it to true.  I 
then got the following exception (at end of description).

With this option left at true - everytime I start Netbeans 
I get the same exception.  If I set it to false and start 
netbeans it doesnt give me the exception.  The option does 
save and does work though.

Annotation: Exception occurred in Request Processor
java.lang.NullPointerException
        at org.openide.loaders.InstanceNode.initName
(InstanceNode.java:272)
        at org.openide.loaders.InstanceNode.<init>
(InstanceNode.java:81)
        at org.openide.loaders.InstanceNode.<init>
(InstanceNode.java:67)
        at 
org.openide.loaders.InstanceDataObject.createNodeDelegateIm
pl(InstanceDataObject.java:470)
        at 
org.openide.loaders.InstanceDataObject.createNodeDelegate
(InstanceDataObject.java:419)
        at org.openide.loaders.DataObject$1.run
(DataObject.java:253)
        at org.openide.util.Mutex.readAccess
(Mutex.java:237)
        at org.openide.loaders.DataObject.getNodeDelegate
(DataObject.java:249)
        at org.openide.loaders.DataNode$2.run
(DataNode.java:517)
        at org.openide.util.Task.run(Task.java:136)
[catch] at org.openide.util.RequestProcessor$Processor.run
(RequestProcessor.java:599)
Comment 1 David Strupl 2003-02-23 23:10:48 UTC
Changing subcomponent (and owner ;-)
Comment 2 David Konecny 2003-02-26 13:07:57 UTC
The problem isn't directly in the settings system. From the exception
it looks that some action is incorrectly implemented and returns null
instead of its name. I added some gisnostic which should report the
class name of the action. The problem is not related to "file
extension setting". If the action class is reported the issue against
the module which provides the class must be filed.

Fixed in:
Checking in src/org/openide/loaders/InstanceNode.java
new revision: 1.27; previous revision: 1.26
Comment 3 pzajac 2003-03-12 10:50:26 UTC
it works fine
Comment 4 risto09q894 2004-01-28 09:18:17 UTC
I got a RuntimeException telling me to "Please attach following
information to the issue
<http://www.netbeans.org/issues/show_bug.cgi?id=31227>". I have NB
3.5.1, Win 2000, jdk 1.4.1_02 (the one bundled with JBuilder 9 trial).
Here is the info:

SystemAction de.hunsicker.jalopy.plugin.netbeans.FormatAction does not
implement getName() properly. It returns null!
at org.openide.loaders.InstanceNode.initName(InstanceNode.java:280)
	at org.openide.loaders.InstanceNode.<init>(InstanceNode.java:78)
	at org.openide.loaders.InstanceNode.<init>(InstanceNode.java:64)
	at
org.openide.loaders.InstanceDataObject.createNodeDelegateImpl(InstanceDataObject.java:463)
	at
org.openide.loaders.InstanceDataObject.createNodeDelegate(InstanceDataObject.java:412)
	at org.openide.loaders.DataObject$1.run(DataObject.java:242)
	at org.openide.util.Mutex.readAccess(Mutex.java:239)
	at org.openide.loaders.DataObject.getNodeDelegate(DataObject.java:238)
	at
org.openide.loaders.DataObject.getClonedNodeDelegate(DataObject.java:263)
	at
org.openide.loaders.FolderChildren.createNodes(FolderChildren.java:132)
	at org.openide.nodes.Children$Keys$KE.nodes(Children.java:1983)
	at org.openide.nodes.ChildrenArray.nodesFor(ChildrenArray.java:109)
	at org.openide.nodes.Children$Info.nodes(Children.java:1077)
	at org.openide.nodes.Children.justComputeNodes(Children.java:583)
	at org.openide.nodes.ChildrenArray.nodes(ChildrenArray.java:54)
	at org.openide.nodes.Children.getNodes(Children.java:325)
	at org.openide.loaders.FolderChildren.getNodes(FolderChildren.java:155)
	at org.openide.loaders.FolderChildren.findChild(FolderChildren.java:163)
	at org.openide.nodes.NodeOp.findChild(NodeOp.java:221)
	at org.openide.nodes.NodeOp.findPath(NodeOp.java:239)
	at org.openide.nodes.NodeOp.findPath(NodeOp.java:267)
	at
org.openide.explorer.ExplorerManager.findPath(ExplorerManager.java:700)
	at org.openide.explorer.ExplorerManager$6.run(ExplorerManager.java:642)
	at org.openide.util.Task.run(Task.java:136)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:328)
[catch] at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:670)
Comment 5 David Konecny 2004-01-28 12:47:08 UTC
The error is in 

  de.hunsicker.jalopy.plugin.netbeans.FormatAction 

class. If it is annoying you should file your comment against the
Jalopy module on the website from which you downloaded that module.
Comment 6 Andrei Badea 2005-02-24 16:54:02 UTC
action org.netbeans.core.windows.actions.MaximizeWindowAction does not
implement SystemAction.getName() or Action.getValue(NAME) properly. It
returns null!
Comment 7 _ pcw 2007-03-22 00:44:44 UTC
I reopened this because I got the following message in the console while running
NB 6.0 (build from around 3/12/2007):

WARNING [org.openide.loaders]: Please attach following information to the issue
<http://www.netbeans.org/issues/show_bug.cgi?id=31227>: action
org.netbeans.modules.java.editor.overridden.IsOverriddenAnnotationAction does
not implement SystemAction.getName() or Action.getValue(NAME) properly. It
returns null!
Comment 8 Marian Mirilovic 2007-04-02 08:34:22 UTC
pcw, 
I reported your last post into separate issue against java/editor - see issue 99638
Comment 9 nouar38 2007-05-29 16:01:47 UTC
with NB 6.0 200721051800 got this message (on solaris-sparc)

WARNING [org.openide.loaders]: Please attach following information to the issue
<http://www.netbeans.org/issues/show_bug.cgi?id=31227>: action
org.netbeans.modules.db.sql.editor.ui.actions.ConnectionAction does not
implement SystemAction.getName() or Action.getValue(NAME) properly. It returns null!

may be I should open another issue against another component, please advice
thanks.
Comment 10 Vladimir Voskresensky 2007-08-17 18:06:38 UTC
NetBeans IDE Dev (Build 070817)

 Please attach following information to the issue <http://www.netbeans.org/issues/show_bug.cgi?id=31227>: action
org.netbeans.modules.uml.integration.netbeans.actions.ReverseEngineerAction does not implement SystemAction.getName() or
Action.getValue(NAME) properly. It returns null!
Comment 11 unr303 2008-01-25 07:48:39 UTC
WARNING [org.openide.loaders]: Please attach following information to the issue
<http://www.netbeans.org/issues/show_bug.cgi?id=31227>: action
org.netbeans.modules.uml.integration.netbeans.actions.ReverseEngineerAction does not implement SystemAction.getName() or
Action.getValue(NAME) properly. It returns null!

  Product Version         = NetBeans IDE 6.0 (Build 200711261600)
  Operating System        = Windows XP version 5.1 running on x86
Comment 12 ahadsell 2008-01-27 23:49:45 UTC
When trying to rename a class using refactor/rename
Platform: Windows XP SP2
Java 1.6.0_03 (Sun)

WARNING [org.openide.loaders]: Please attach following information to the issue
<http://www.netbeans.org/issues/show_bug.cgi?id=31227>: action
org.netbeans.modules.uml.integration.netbeans.actions.ReverseEngineerAction does not implement SystemAction.getName() or
Action.getValue(NAME) properly. It returns null!
SEVERE [global]
java.lang.NullPointerException
        at org.netbeans.modules.visualweb.insync.java.JavaClass$1.run(JavaClass.java:131)
        at org.netbeans.modules.visualweb.insync.java.ReadTaskWrapper.run(ReadTaskWrapper.java:73)
        at org.netbeans.modules.visualweb.insync.java.ReadTaskWrapper.run(ReadTaskWrapper.java:56)
        at org.netbeans.api.java.source.JavaSource.runUserActionTask(JavaSource.java:616)
        at org.netbeans.modules.visualweb.insync.java.ReadTaskWrapper.execute(ReadTaskWrapper.java:80)
        at org.netbeans.modules.visualweb.insync.java.ReadTaskWrapper.execute(ReadTaskWrapper.java:88)
        at org.netbeans.modules.visualweb.insync.java.JavaClass.isSubTypeOf(JavaClass.java:128)
        at org.netbeans.modules.visualweb.insync.models.FacesModel.openJavaUnits(FacesModel.java:819)
        at org.netbeans.modules.visualweb.insync.models.FacesModel.syncImpl(FacesModel.java:1051)
        at org.netbeans.modules.visualweb.insync.Model.sync(Model.java:219)
        at
org.netbeans.modules.visualweb.insync.faces.refactoring.FacesRefactoringUtils.isJavaFileObjectOfInterest(FacesRefactoringUtils.java:231)
        at
org.netbeans.modules.visualweb.insync.faces.refactoring.FacesRefactoringsPluginFactory.createInstance(FacesRefactoringsPluginFactory.java:141)
        at org.netbeans.modules.refactoring.api.AbstractRefactoring.getPlugins(AbstractRefactoring.java:131)
        at org.netbeans.modules.refactoring.api.AbstractRefactoring.addProgressListener(AbstractRefactoring.java:257)
        at org.netbeans.modules.refactoring.spi.impl.ParametersPanel.showDialog(ParametersPanel.java:448)
        at org.netbeans.modules.refactoring.spi.impl.RefactoringPanel.refresh(RefactoringPanel.java:605)
        at org.netbeans.modules.refactoring.spi.impl.RefactoringPanel.<init>(RefactoringPanel.java:139)
        at org.netbeans.modules.refactoring.spi.ui.UI.openRefactoringUI(UI.java:83)
        at
org.netbeans.modules.refactoring.java.ui.RefactoringActionsProvider$TextComponentTask.run(RefactoringActionsProvider.java:566)
        at org.netbeans.modules.refactoring.java.RetoucheUtils.invokeAfterScanFinished(RetoucheUtils.java:900)
        at org.netbeans.modules.refactoring.java.ui.RefactoringActionsProvider.doRename(RefactoringActionsProvider.java:156)
        at
org.netbeans.modules.refactoring.api.impl.ActionsImplementationFactory.doRename(ActionsImplementationFactory.java:69)
        at org.netbeans.modules.refactoring.spi.impl.RenameAction.performAction(RenameAction.java:62)
        at org.netbeans.modules.refactoring.spi.impl.RefactoringGlobalAction.performAction(RefactoringGlobalAction.java:131)
        at org.openide.util.actions.NodeAction.performAction(NodeAction.java:289)
        at org.openide.util.actions.CallableSystemAction$1.run(CallableSystemAction.java:118)
        at org.netbeans.modules.openide.util.ActionsBridge.doPerformAction(ActionsBridge.java:77)
        at org.openide.util.actions.CallableSystemAction.actionPerformed(CallableSystemAction.java:114)
        at org.openide.util.actions.NodeAction.actionPerformed(NodeAction.java:277)
        at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
        at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
        at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
        at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
        at javax.swing.AbstractButton.doClick(AbstractButton.java:357)
        at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1216)
        at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1257)
        at java.awt.Component.processMouseEvent(Component.java:6038)
        at javax.swing.JComponent.processMouseEvent(JComponent.java:3265)
        at java.awt.Component.processEvent(Component.java:5803)
        at java.awt.Container.processEvent(Container.java:2058)
        at java.awt.Component.dispatchEventImpl(Component.java:4410)
        at java.awt.Container.dispatchEventImpl(Container.java:2116)
        at java.awt.Component.dispatchEvent(Component.java:4240)
        at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4322)
        at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3986)
        at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3916)
        at java.awt.Container.dispatchEventImpl(Container.java:2102)
        at java.awt.Window.dispatchEventImpl(Window.java:2429)
        at java.awt.Component.dispatchEvent(Component.java:4240)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
[catch] at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)

Comment 13 Lukas Hasik 2008-01-28 09:38:25 UTC
1, WARNING [org.openide.loaders]: Please attach following information to the issue
<http://www.netbeans.org/issues/show_bug.cgi?id=31227>: action
org.netbeans.modules.db.sql.editor.ui.actions.ConnectionAction does not
implement SystemAction.getName() or Action.getValue(NAME) properly. It returns null!

reported to db as issue 126067

2, org.netbeans.modules.uml.integration.netbeans.actions.ReverseEngineerAction does not implement SystemAction.getName()
or Action.getValue(NAME) properly. It returns null!

-reported to uml as issue 126066 
Comment 14 unr303 2008-01-29 18:54:40 UTC
Is issue really fixed? Perhaps it should be reopened?
Comment 15 Peter Lam 2008-02-12 23:22:46 UTC
While testing Ubuntu Hardy, I saw the following in the ide log file so attached it here.

WARNING [org.openide.loaders]: Please attach following information to the issue
<http://www.netbeans.org/issues/show_bug.cgi?id=31227>: action
org.netbeans.modules.uml.integration.netbeans.actions.ReverseEngineerAction does not implement SystemAction.getName() or
Action.getValue(NAME) properly. It returns null!
SEVERE [org.openide.util.RequestProcessor]
java.lang.NullPointerException: null attribute
	at sun.print.IPPPrintService.isAttributeValueSupported(IPPPrintService.java:1176)
	at sun.print.ServiceDialog$OrientationPanel.updateInfo(ServiceDialog.java:2164)
	at sun.print.ServiceDialog$PageSetupPanel.updateInfo(ServiceDialog.java:1280)
	at sun.print.ServiceDialog.updatePanels(ServiceDialog.java:454)
	at sun.print.ServiceDialog.initPrintDialog(ServiceDialog.java:212)
	at sun.print.ServiceDialog.<init>(ServiceDialog.java:141)
	at javax.print.ServiceUI.printDialog(ServiceUI.java:206)
	at sun.print.RasterPrinterJob.printDialog(RasterPrinterJob.java:880)
	at sun.print.PSPrinterJob.printDialog(PSPrinterJob.java:439)
	at org.openide.text.CloneableEditorSupport.print(Unknown Source)
	at org.openide.actions.PrintAction.performAction(Unknown Source)
	at org.openide.util.actions.NodeAction.performAction(Unknown Source)
	at org.openide.util.actions.CallableSystemAction$1.run(Unknown Source)
	at org.netbeans.modules.openide.util.ActionsBridge$ActionRunnable.actionPerformed(Unknown Source)
	at org.netbeans.core.ModuleActions.invokeAction(Unknown Source)
	at org.netbeans.modules.openide.actions.ActionsBridgeImpl.invokeAction(Unknown Source)
	at org.netbeans.modules.openide.util.ActionsBridge$ActionRunnable.doRun(Unknown Source)
	at org.netbeans.modules.openide.util.ActionsBridge$1.run(Unknown Source)
[catch] at org.openide.util.RequestProcessor$Task.run(Unknown Source)
	at org.openide.util.RequestProcessor$Processor.run(Unknown Source)
Comment 16 Peter Lam 2008-02-12 23:23:14 UTC
See attached ide for complete info.
Comment 17 Peter Lam 2008-02-12 23:23:44 UTC
Created attachment 56563 [details]
ide log


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo