Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 30932 - Context menu sometimes does not work in TreeTable
Context menu sometimes does not work in TreeTable
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Explorer
3.x
PC Windows ME/2000
: P2 (vote)
: 3.x
Assigned To: Jiri Rechtacek
issues@platform
:
: 23952 25889 30486 31809 (view as bug list)
Depends on:
Blocks: 31016
  Show dependency treegraph
 
Reported: 2003-02-11 10:33 UTC by Jan Jancura
Modified: 2008-12-22 20:35 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Context menu for breakpoints view in debugger window (10.40 KB, image/gif)
2003-02-11 10:34 UTC, Jan Jancura
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Jancura 2003-02-11 10:33:24 UTC
Context menu for !!getContextActions!! sometimes
does not work in TreeTable (standart context menu
is shown).
This problem blocks major functionality in debugger...
Comment 1 Jan Jancura 2003-02-11 10:34:18 UTC
Created attachment 8888 [details]
Context menu for breakpoints view in debugger window
Comment 2 Jan Jancura 2003-02-11 10:35:10 UTC
*** Issue 30486 has been marked as a duplicate of this issue. ***
Comment 3 _ ttran 2003-02-13 22:34:25 UTC
pzavadsky: can this be related to changes in Actions you made recently?
Comment 4 Peter Zavadsky 2003-02-14 13:32:39 UTC
It could be.

But first what does it mean it is not working? Does it mean that those
menu items are disabled?
If yes there is probably the problem when constructing the popup,
either the context isn't used or the context is bad. Just guessing.

Please provide the answer to my question first.
Comment 5 Jan Jancura 2003-02-14 15:43:39 UTC
> Does it mean that those menu items are disabled?

No they are not visible at all.

I sit on the same floor, if you need some presentation ;))
Comment 6 Jan Jancura 2003-02-14 16:37:47 UTC
*** Issue 23952 has been marked as a duplicate of this issue. ***
Comment 7 Peter Zavadsky 2003-02-17 08:24:03 UTC
Please describe it more precisely.

Is the popup visible and just a couple of items not? If yes, which
ones? Or the entire popup isn't visible.

(Call me when you are in your office :-) ).
Comment 8 Jan Jancura 2003-02-21 17:30:58 UTC
*** Issue 25889 has been marked as a duplicate of this issue. ***
Comment 9 Jiri Rechtacek 2003-02-26 16:33:56 UTC
the context actions (from root nodes) are added to popup if none nodes
are selected
Comment 10 Jiri Rechtacek 2003-03-24 16:17:02 UTC
*** Issue 31809 has been marked as a duplicate of this issue. ***
Comment 11 _ mihmax 2003-04-04 10:56:20 UTC
Fixed, but why is it still TBD?!!
Comment 12 Lukas Hasik 2003-09-05 10:31:52 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo