Bug 30767 - Installer Hange 99% CPU on Clean Install on ALL OS
Installer Hange 99% CPU on Clean Install on ALL OS
Status: VERIFIED INVALID
Product: installer
Classification: Unclassified
Component: Code
3.x
All All
: P1 with 4 votes (vote)
: 3.x
Assigned To: issues@installer
issues@installer
:
: 32113 32647 33123 33945 34091 34289 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-06 14:35 UTC by jgordon
Modified: 2004-03-03 22:12 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jgordon 2003-02-06 14:35:00 UTC
I have both XP Pro and Home on a PC. Both patched up to 
the latest fixes from Microsoft.
On either OS if I try to install NetBeans 3.4.1 I can 
press 'Next' after specifying which directory I want to 
install into and then the CPU goes up to 99%.
I am then allowed to press the 'Next' button again, at 
which time the hour glass appears and the CPU goes to 99% 
and it hangs.
BUT...
If I install 3.4 on the same OS and then try and install 
3.4.1 and tell it to upgrade the existing installation it 
works correctly and the installer finishes.
BUT...
If I then try to un-install the above it says that the un-
installer finished, but NetBeans is still displayed in the 
list of installed programs and it has removed nothing.
(Maybe this last part should be a seperate Issue)?
Comment 1 abrown 2003-03-14 11:32:12 UTC
i have encountered the same problem described in the first part of the
report. however i am running win2k sp3, j2sdk1.4.0_01, j2sdkee1.3.1
Comment 2 richardchandler 2003-03-27 18:37:22 UTC
I have same problem installing 3.4.1 on a win2k/jdk1.3 
system.
I had just uninstalled 3.4 successfully leaving the .cfg 
file.
I get choose install dir, when I click next it hangs with 
99% cpu use
Comment 3 keebz 2003-04-04 20:40:25 UTC
I have the same problem installing 3.4.1 on Win XP Pro with
j2sdk1.4.0_02 installed. I could install 3.4 with no problem.
Comment 4 kanderson 2003-04-07 02:03:14 UTC
Happens for me on Win2k SP3 with JDK 1.4.1_02
Comment 5 jgordon 2003-04-24 09:16:12 UTC
Just a thought, maybe running XP in safe mode and loging 
in as administrator would allow the installer to work.
It might be that a supervisor account in XP is not the 
same as the administrator account.
Comment 6 Richard Gregor 2003-05-15 08:12:14 UTC
Scheduled for 4.0. Needs more investigation.
Comment 7 Richard Gregor 2003-05-15 08:14:30 UTC
*** Issue 32113 has been marked as a duplicate of this issue. ***
Comment 8 Richard Gregor 2003-05-15 08:29:32 UTC
*** Issue 32647 has been marked as a duplicate of this issue. ***
Comment 9 Jan Chalupa 2003-05-16 08:05:42 UTC
There are 5 reports of the problem in this report and there are about
the same number of duplicates logged in IZ. The users are unable to
install the product -- this sounds like a P1 (not P3) and needs to be
investigated now (not for 4.0).
Comment 10 Richard Gregor 2003-05-16 08:25:40 UTC
OK, but there is a workaround and it is not common problem - I was
unable to reproduce it. Also destination bean is property of IS so I
can hardly change code of it.   
Comment 11 _ ttran 2003-05-16 11:26:19 UTC
> there is a workaround and it is not common problem

based on what we see on the mailing lists, this is becoming more and
more common problems.  IMO the installer must be rock-solid.

What is the a workaround you're talking about?  I couldn't see it in
this bug report. Have we analyzed the problem to know what the cause
is or can be?

Thx
Comment 12 Richard Gregor 2003-05-16 11:58:45 UTC
It is hard to analyze problem when I'm not able to reproduce it.If
anyone from QA is then I'll investigate. I know that there was some
installer freeze on Linux and as workaround there was enough to use
CTRL+/ (should be the same as CTRL+Break on Win)which causes thread
dump and then installer continued.
Comment 13 Richard Gregor 2003-05-28 19:24:03 UTC
*** Issue 33945 has been marked as a duplicate of this issue. ***
Comment 14 Richard Gregor 2003-06-03 07:32:28 UTC
*** Issue 33123 has been marked as a duplicate of this issue. ***
Comment 15 Richard Gregor 2003-06-03 07:42:22 UTC
*** Issue 34091 has been marked as a duplicate of this issue. ***
Comment 16 Richard Gregor 2003-06-04 07:23:19 UTC
This one is probably release note candidate.
Comment 17 Richard Gregor 2003-06-04 09:37:52 UTC
Here is snip of mail from Frank Cohen about his investigation:

Frank Cohen wrote:
Hi Tim: I tried running the installer on other JVMs:

Java 1.3.1 - passed
Java 1.4.0 - failed
Java 1.4.1 - passed
Java 1.5.2 beta - passed

So the problem is NB3.5rc3 installer is not compatible with Java
1.4.0. Would you mind putting this into issuezilla - seems like
something that should go into the readme file or maybe in the faq on
the download site.

-Frank 
Comment 18 Patrick Keegan 2003-06-04 14:41:00 UTC
Proposed relnote. I say a lot here, so I hope several people will have
a look.

The installer sometimes hangs when doing a clean install (not
upgrading a previous version of the IDE) after selecting the
installationd directory in the wizard. This bug has been encountered
on some Windows and Linux systems but has not been isolated.

Some possible workarounds:
*Try a different JDK version. The bug appears to be most common on JDK
version 1.4.0.
*Accept the default installation directory.
*If you have a previous version of the IDE installed, select the
upgrade option when installing.
*If you are running on a Linux system, pressing Ctrl-\ sometimes stops
the hang.
*If you are running on a Windows XP system, check your permissions.
You may need to logon as administrator or set administrator privileges
for yourself to get the installer to work correctly.
Comment 19 Richard Gregor 2003-06-04 14:48:22 UTC
Thanks Patrick. 
Only one comment "*If you have a previous version of the IDE
installed, select the
upgrade option when installing" should be "If you have a previous
version of the IDE installed, select the
import option when installing" . I have talked with user and the right
one should be import. Upgrade doesn't exist in 3.5 installer.
Comment 20 Patrick Keegan 2003-06-04 15:50:25 UTC
OK. I guess I should also change 
"(not upgrading a previous version of the IDE)"

to

"(not
importing settings from a previous version of the IDE)"
Comment 21 Richard Gregor 2003-06-05 07:22:39 UTC
Good point! Thanks Patrick.
Comment 22 amycwhitfield 2003-06-18 18:36:53 UTC
I am having the same problems.  I currently have Windows XP Home
edition and the NetBeans installer hangs on the dialog panel for
selecting the destination directory.  I have only tried installing the
latest version, I will try v3.4 next.
Comment 23 amycwhitfield 2003-06-18 18:42:54 UTC
Able to install v3.4.1 on WindowsXP Home successfully, but not v3.5
(indefinitely hangs on destination directory panel).
Comment 24 Richard Gregor 2003-06-24 10:59:31 UTC
*** Issue 34289 has been marked as a duplicate of this issue. ***
Comment 25 dmladek 2003-08-01 14:05:23 UTC
Changing subject and OS and Platforms according reflect duplicates....
This is not problem of any OS, but of installer itself.

Please see my latest comment in the dup. issue #32693 :
-------  From Daniel Mladek 2003-08-01 06:01 PDT -------


And try to investigate the reason why you can't install the product
more times.... or why sometimes you could...
Comment 26 George Hernandez 2004-01-28 21:05:15 UTC
The new ismp5 installers appear to be running on all platforms. If
this problem is again found, please write a new bug specifying the
ismp5 installers. Will mark this as invalid now.
Comment 27 dmladek 2004-02-02 14:43:10 UTC
OK
Comment 28 Patrick Keegan 2004-03-03 22:12:15 UTC
removing RELNOTE keyword


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo