Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 29955 - Need to show Makefile targets in the Navigator
Need to show Makefile targets in the Navigator
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: -- Other --
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Alexey Vladykin
issues@cnd
:
: 27359 (view as bug list)
Depends on:
Blocks: 178733
  Show dependency treegraph
 
Reported: 2003-01-10 19:16 UTC by _ gordonp
Modified: 2010-02-03 10:12 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ gordonp 2003-01-10 19:16:09 UTC
It would be nice if a Makefile displayed in the
Explorer were displayed with its targets as children
(similar to how classes are shown as children of a
Java file). If the parent node were selected then
the default Makefile target should be run unless
overridden via property). If a specific target is
selected then that target should be run.
Comment 1 Thomas Preisler 2003-08-06 22:36:15 UTC
*** Issue 27359 has been marked as a duplicate of this issue. ***
Comment 2 soldatov 2007-12-18 13:45:14 UTC
Or Makefile targets should be displayed in Navigator tab
Comment 3 Alexey Vladykin 2010-02-02 01:57:59 UTC
Mostly done. After changeset http://hg.netbeans.org/cnd-main/rev/1313c7614cea you can see makefile targets in the navigator and even go to source on double-click.
Will also add ability to run target soon.
Comment 4 Alexey Vladykin 2010-02-03 10:12:36 UTC
"Run Target" submenu in Makefile context menu now lists targets extracted from the makefile.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo