Bug 29078 - Cannot update some nbm's from Alpha Update Center
Cannot update some nbm's from Alpha Update Center
Product: www
Classification: Unclassified
Component: Builds & Repositories
PC Windows ME/2000
: P1 (vote)
Assigned To: rnovak
Depends on:
  Show dependency treegraph
Reported: 2002-11-28 08:40 UTC by akemr
Modified: 2003-03-04 13:46 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT


Note You need to log in before you can comment on or make changes to this bug.
Description akemr 2002-11-28 08:40:00 UTC
info.xml files of some nbm's (e.g. metrics.nbm,
mdr ..) on
for NB 3.3.2 (or S1S 4.1) includes following header:

<!DOCTYPE module PUBLIC "-//NetBeans//DTD
Autoupdate Module Info 1.0//EN"

which cause exception:
java.net.UnknownHostException: www.netbeans.org

and then updater unexpectedly freezes!

autoupdate-info-1_0.dtd was added into updater.jar
in NetBeans 3.4,
so you should omit this header from nbm's for NB < 3.4

If you use simple form (without <!DOCTYPE.. ) like
<?xml version="1.0" encoding="UTF-8"?>
<module codenamebase="..

then updater will work without problems.

See also "Problem autoupdating from netbeans
update center" thread on nbusers.
Comment 1 Jesse Glick 2002-11-28 13:12:58 UTC
To clarify: for NB 3.4+ no change needs to be made, nor should be
made; only for NB 3.3 and before.
Comment 2 Jesse Glick 2003-02-28 17:02:52 UTC
What is the status here? This was filed as a P1 three months ago,
without so much as a response! Please evaluate, give estimate for
completion, etc.
Comment 3 rnovak 2003-02-28 20:14:55 UTC
I appologize for late respond.
I'll fix it as soon as possible.
Comment 4 rnovak 2003-03-04 13:46:01 UTC
<!DOCTYPE.. tag was removed from NBMs of modules published for
Netbeans 3.3.2.
It seems, that update of all NBMs from Alpha Update Center for NB
3.3.2 works fine.

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo