Bug 27995 - Go to line loses focus.
Go to line loses focus.
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: -- Other --
3.x
All All
: P3 (vote)
: 3.x
Assigned To: issues@editor
issues@editor
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-14 17:07 UTC by ehucka
Modified: 2007-11-05 13:44 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ehucka 2002-10-14 17:07:38 UTC
System: Linux 2.4.9 i686 RedHat 7.2 (Enigma)
        GNOME WM sawfish
        JKD 1.4.1 build 21
        NetBeans IDE Dev (Build 200210140100)

Reproduce:
1. Open Java file (better with guarded block)
2. Invoke Ctrl+G action - open Go to Line dialog
3. Write some number of line exists in this file
4. Press Goto
Result: Cursor in the file is lost. Properties are
set to destination method and class.
Comment 1 Martin Roskanin 2002-10-15 10:55:23 UTC
Duplicate of the issue #25337
The behaviuor is similar as in find dialog. Although it can be 
reproduced even via mouse click.

*** This issue has been marked as a duplicate of 25337 ***
Comment 2 ehucka 2002-10-21 09:51:58 UTC
I cannot reproduce this bug with nbdev 200210210100.
Comment 3 Jan Lahoda 2003-01-20 12:50:19 UTC
Hi,
    I am able to reproduce this on 200301200100, and even using
current standalone editor. So, I think it is either bug of editor or
bug of swing.
Comment 4 pzajac 2003-01-29 16:06:29 UTC
I can reproduce it on [200301290100], RedHat 7.2 + KDE  desktop + KD
1.4.1 build 21. 
Comment 5 Martin Roskanin 2003-01-30 09:59:55 UTC
fixed in [maintrunk]

Please verify, I couldn't reproduce the bug.

/cvs/editor/libsrc/org/netbeans/editor/ext/GotoDialogSupport.java,v 
<--  GotoDialogSupport.java
new revision: 1.13; previous revision: 1.12

Comment 6 ehucka 2003-01-31 11:40:50 UTC
I've reproduced it in 200301310100.
Comment 7 Martin Roskanin 2003-02-01 14:35:59 UTC
fixed in [maintrunk]

I hope this should fix it. Please, verify. Thanks.

/cvs/editor/libsrc/org/netbeans/editor/ext/GotoDialogSupport.java,v 
<--  GotoDialogSupport.java
new revision: 1.14; previous revision: 1.13
Comment 8 ehucka 2003-04-09 11:16:34 UTC
I could reproduce it again in Nevada build 030407. It is not as
frequent as before but it is possible to reproduce it.
Comment 9 Miloslav Metelka 2004-01-20 14:26:43 UTC
Petre, could you please verify whether this still happens even with
the new windowing system? Thanks.
Comment 10 pfelenda 2004-01-20 15:08:25 UTC
I am not able to reproduce it on last dev build [200401191900].
This isssue is related to old window systems.
Comment 11 Miloslav Metelka 2004-01-21 17:13:08 UTC
I'm closing this issue as fixed. Please reopen if necessary.
Comment 12 ehucka 2004-03-08 11:46:57 UTC
Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo