Bug 27407 - NetBeans web backward compatible
NetBeans web backward compatible
Status: RESOLVED INVALID
Product: obsolete
Classification: Unclassified
Component: collabnet
3.x
PC Linux
: P2 (vote)
: TBD
Assigned To: issues@www
issues@www
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-18 09:21 UTC by _ lkramolis
Modified: 2009-11-08 02:30 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ lkramolis 2002-09-18 09:21:12 UTC
Because of new NetBeans web design a lot of
bookmarks became inaccessible. In Utilities module
I had to change almost all URLs, but 
old NetBeans releases contain original links. And
also references from external pages become wrong,
e.g. now I found link at Project XEMO to
<http://www.netbeans.org/articles/nb-cvs-33.html>
that was moved to
<http://www.netbeans.org/ide/docs/nb-cvs-33.html>.
I am sure it is not only one example.

I would like to ask web-masters to reactivate old
pages to redirect to a new location.
Comment 1 jcatchpoole 2002-09-19 15:31:07 UTC
Every effort is made to redirect high-traffic pages of 
course, but finding those in the IDE is something we did not
catch.

Libor, how do we get a list of URLs used in the IDE that
we should redirect ?  Thanks.
Comment 2 _ lkramolis 2002-09-19 16:14:02 UTC
I can speak just about Utilities modules (it adds URL bookmarks to
NB), e.g. in NB 3.3:
http://utilities.netbeans.org/source/browse/utilities/src/org/netbeans/modules/utilities/Layer.xml?rev=1.29.14.2&content-type=text/x-cvsweb-markup&only_with_tag=release33

But I think all "reasonable" pages removed from www/www at time of NB
web reorganization should be reactivated, e.g. www/articles:
http://xml.netbeans.org/source/browse/www/www/articles/Attic/
Comment 3 jcatchpoole 2003-06-19 13:35:55 UTC
RE - redirecting all reasonable pages ... not sure about
this, what exactly is "reasonable" ? :-)  I think *most*
pages would end up being reasonable, and we would have
way too many redirects all over the place.

RE - key URLs in the IDE : definitely should try to make
some permanent URLs which never change, and work for all
past NB releases.  See issue 34149 for that.

*** This issue has been marked as a duplicate of 34149 ***
Comment 4 Marian Mirilovic 2009-11-08 02:30:55 UTC
We recently moved out from Collabnet's infrastructure


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo