Bug 270021 - No access to breakpoint properties - can't create conditional breakpoint
No access to breakpoint properties - can't create conditional breakpoint
Status: RESOLVED DUPLICATE of bug 132066
Product: php
Classification: Unclassified
Component: Debugger
8.2
All All
: P3 (vote)
: TBD
Assigned To: issues@php
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-08 19:11 UTC by nerdlinger
Modified: 2017-06-01 00:21 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
In the editor and breakpoint windows (99.66 KB, image/jpeg)
2017-03-08 19:11 UTC, nerdlinger
Details
messages.log file (44.23 KB, text/plain)
2017-03-09 16:17 UTC, nerdlinger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nerdlinger 2017-03-08 19:11:27 UTC
Created attachment 163796 [details]
In the editor and breakpoint windows

Right-click on breakpoint in editor has contextual menu with "Breakpoint > Properties" item, but it's disabled. No "Properties" or "Customize" item in the contextual menu when right-clicking a breakpoing in the Breakpoints window.

Breakpoint creation working fine, execution halts at breakpoint, breakpoint shows up in breakpoints window. Can't create a conditional breakpoint!
Comment 1 Maria Tishkova 2017-03-09 05:37:09 UTC
Please let us know what is the project you are workin on?
Java? C/C++?
Comment 2 Maria Tishkova 2017-03-09 05:38:55 UTC
Please attach messages.log file. It is placed under <userdir>/var/log folder
Comment 3 nerdlinger 2017-03-09 16:12:13 UTC
The project is PHP
Comment 4 nerdlinger 2017-03-09 16:17:30 UTC
Created attachment 163808 [details]
messages.log file
Comment 5 Tomas Mysik 2017-03-24 13:58:43 UTC
Yes, conditional breakpoints are not implemented for PHP.

Thanks for reporting.
Comment 6 junichi11 2017-06-01 00:21:02 UTC

*** This bug has been marked as a duplicate of bug 132066 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo