Bug 269822 - Netbeans no longer offers to download output files from remote build host
Netbeans no longer offers to download output files from remote build host
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Remote
8.2
PC Windows 7
: P2 (vote)
: 8.2
Assigned To: Vladimir Kvashin
issues@cnd
82patch2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-02-14 13:38 UTC by Quant
Modified: 2017-04-21 17:31 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
project propeties tree screenshot (9.70 KB, image/png)
2017-02-20 13:27 UTC, Quant
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Quant 2017-02-14 13:38:10 UTC
Netbeans 8.2 under Windows is used to develop applications for the Raspberry Pi, including Qt based, wherein the Raspberry Pi serves as the remote build host. The project are set in the simple development mode (SFTP). Theey build and run alright.
According to the tutorial (https://netbeans.org/kb/docs/cnd/remotedev-tutorial.html#tips)
"If building your project remotely compiles libraries or generates other files in addition to the main build product, the IDE prompts you to download the files to the local system. You can select which changed files to download."

The problem that this no longer happens: it neither downloads anything nor prompts me.
Comment 1 Vladimir Kvashin 2017-02-20 07:50:24 UTC
The IDE probably just does not "know", which file is the result of your build. In the case of managed project (i.e. when you choose "Application Project", "Dynamic Library" or "Static Library" when creating your project) IDE knows everything about your code. If you choose "project from existing code" or "project from binary", IDE probably just do not know what's the result of the build, so it does not know what to download.

If that's the case, then please go to Project Properties, choose "Build > Make" in the tree to the left, and fill "build result" field. IDE then will prompt tp download this file after build.
Comment 2 Vladimir Kvashin 2017-02-20 10:58:06 UTC
I see that indeed strange things happen with downloading changed files in 8.2. I think I'll fix this in an upcoming patch.

Information from you is valuable, however. 
I'd like to know
1) whether you project is managed or based on a custom makefile
2) if it's based on a custom makefile, then please check whether build result is filled properly.

Otherwise I can solve problems that I see with download (they are different from yours), but not your problem.
Comment 3 Vladimir Kvashin 2017-02-20 12:37:33 UTC
There is another thing that can prevent downloading files. In brief, IDE stores information concerning changed files downloads in the file 
nbproject/private/downloads-${host}-${user}-22
This file might get corrupted. 
As a workaround try to do the following:
- quite NetBeans
- remove this file
- restart NetBeans and try again
Comment 4 Quant 2017-02-20 13:27:32 UTC
Created attachment 163670 [details]
project propeties tree screenshot

No Build>Make
Comment 5 Quant 2017-02-20 13:53:52 UTC
Hi,
first of all there is no Build>Make options (see attachment). This screenshot  is BTW from a minimal "Hello Raspberry Pi" application, that I created with default settings exactly to see if there  a problem with project settings, but the downloading still doesn't work. All my projects are managed by Netbeans.

I probably should have mentioned, that some of the projects are Qt based. And biggest problem with the bug that the files that are generated by moc and especially by uic during building are not  downloaded. Therefore Netbeans can't provide code assistance for them, which is very inconvenient.

Also there is no downloads-*** file in all folders.
Comment 6 soldatov 2017-02-20 14:35:51 UTC
(In reply to Quant from comment #5)
> I probably should have mentioned, that some of the projects are Qt based.
> And biggest problem with the bug that the files that are generated by moc
> and especially by uic during building are not  downloaded. Therefore
> Netbeans can't provide code assistance for them, which is very inconvenient.
No. By design in most cases on local host user hasn't any compilers. IDE parses files on "remote host". You key problem you uses Linux-ARM. On Linux-ARM you needs configure project by hands,
Comment 7 soldatov 2017-02-20 14:50:50 UTC
Such scenario works nicely:
- Add Raspberry Pi host in SFTP mode
- Create "Hello Qt World" project
- Build project
==> "Download HelloQtWorld_2, moc_HelloForm.cpp and ui_HelloForm.h" wizard appears
Comment 8 Quant 2017-02-20 15:43:34 UTC
(In reply to soldatov from comment #7)
> Such scenario works nicely:
> - Add Raspberry Pi host in SFTP mode
> - Create "Hello Qt World" project
> - Build project
> ==> "Download HelloQtWorld_2, moc_HelloForm.cpp and ui_HelloForm.h" wizard
> appears

I did similar thing for similar purposes, the projects builds alright, but I see no dialogue.
Comment 9 Quant 2017-02-21 11:50:23 UTC
(In reply to Vladimir Kvashin from comment #2)
> I see that indeed strange things happen with downloading changed files in
> 8.2. I think I'll fix this in an upcoming patch.
> 
> Information from you is valuable, however. 
> I'd like to know
> 1) whether you project is managed or based on a custom makefile
> 2) if it's based on a custom makefile, then please check whether build
> result is filled properly.
> 
> Otherwise I can solve problems that I see with download (they are different
> from yours), but not your problem.

Do you need any extra information?
Comment 10 Quant 2017-02-22 21:16:02 UTC
I installed Netbeans 8.0.2 that I had used before upgrading to 8.2 to see if it would  work better.
Not really, but playing around with them I found something interesting: in both versions some older projects still get downloaded, but new new ones don't

Is there an option/setting that controls this behavior?
Comment 11 Vladimir Kvashin 2017-03-23 12:45:26 UTC
While investigating this and some other complaints I found a number of related problems and filed an issue 270157 with implementation-wise description of the problems found.

I've just fixed issue 270157. I think this one is resolved as well by these fixes.

I think Monday (Mar 27) morning the will be available in NetBeans daily builds; I encourage you to try it.
Comment 12 Quant 2017-03-28 16:50:31 UTC
(In reply to Vladimir Kvashin from comment #11)
> While investigating this and some other complaints I found a number of
> related problems and filed an issue 270157 with implementation-wise
> description of the problems found.
> 
> I've just fixed issue 270157. I think this one is resolved as well by these
> fixes.
> 
> I think Monday (Mar 27) morning the will be available in NetBeans daily
> builds; I encourage you to try it.

I tried the build 201703280002 and in the process of trying it I found out that the problem is in a space that I have in the name of an upper level folder. If it is removed, the downloading works, even in stable 8.2
Comment 13 Vladimir Kvashin 2017-04-04 12:40:17 UTC
You are right, this is easily reproduced with a path that contains space - even after my recent fixes.
Comment 14 Vladimir Kvashin 2017-04-04 14:08:11 UTC
fixed, change sets 7dbc8d5cfa4e and dfc41470b9ec on enum
Comment 15 Quant 2017-04-10 16:26:37 UTC
(In reply to Vladimir Kvashin from comment #14)
> fixed, change sets 7dbc8d5cfa4e and dfc41470b9ec on enum

I tried build 201704100002, but it doesn't work. Is the fix not yet integrated?
Comment 16 Quality Engineering 2017-04-11 01:53:22 UTC
Integrated into 'main-silver', will be available in build *201704110002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/56e3b3d4f851
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: Fix for #269822 - Netbeans no longer offers to download output files from remote build host
(transplanted from 7dbc8d5cfa4eecba79db4555c8bf8b9572d41c3d)
Comment 17 ilia 2017-04-13 11:14:25 UTC
https://netbeans.org/bugzilla/show_bug.cgi?id=269822 Changesets:
    http://hg.netbeans.org/releases/rev/7dbc8d5cfa4e # Fix for #269822 - Netbeans no longer offers to download output files from remote build host
    http://hg.netbeans.org/releases/rev/dfc41470b9ec # Additional fix for #269822 - Netbeans no longer offers to download output files from remote build host: restore default ON for checkbox
    http://hg.netbeans.org/releases/rev/334e99b517be # i18 after fixing #269822 - Netbeans no longer offers to download output files...
Comment 18 Quant 2017-04-14 13:42:31 UTC
Confirm fixed with build 201704110002.
Спасибо!!
Comment 19 Alexander Pepin 2017-04-21 17:31:41 UTC
Verified by the bug reporter.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo