Bug 269478 - JSON logger is being deprecated
JSON logger is being deprecated
Status: RESOLVED FIXED
Product: php
Classification: Unclassified
Component: PHPUnit
Dev
All All
: P2 (vote)
: Dev
Assigned To: Tomas Mysik
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-01-02 23:07 UTC by twifty
Modified: 2017-01-30 05:52 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description twifty 2017-01-02 23:07:52 UTC
Currently the Unit testing output window makes use of the JSON output generated by PHPUnit. This is deprecated and will be dropped in PHPUnit 6.0. https://github.com/sebastianbergmann/phpunit/issues/2363

The PHPUnit module needs switching to XML.
Comment 1 Tomas Mysik 2017-01-03 12:56:30 UTC
Too bad, we just switched to it in NB 8.2... Will try to "revert" to the JUnit XML format.

Thanks for reporting!
Comment 2 Tomas Mysik 2017-01-28 12:09:27 UTC
Should be done now. There should not be any regressions but still, it is a quite big change so it would be fine if you could test it.

Thanks!

http://hg.netbeans.org/web-main/rev/51e541df961d
Comment 3 Tomas Mysik 2017-01-28 12:11:33 UTC
Of course, there is no support for continuous test results now :/
Comment 4 Quality Engineering 2017-01-29 02:41:50 UTC
Integrated into 'main-silver', will be available in build *201701290002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/51e541df961d
User: Tomas Mysik <tmysik@netbeans.org>
Log: #269478 - JSON logger is being deprecated

Switch back to JUNIT/XML log. Unfortunately, no support for continuous test results.
Comment 5 twifty 2017-01-29 07:46:44 UTC
Thanks for the fix.

It'll be a week or two before I have the time to do any testing due to the Chinese new year, but I'll push it to the top of my list.

It's a shame about the progressive output, but worse is their directing me to a commercial IDE as an alternative.
Comment 6 Tomas Mysik 2017-01-30 05:52:51 UTC
Yes, please, let us know if it works for you (I did some testing and we should be back on XML log as we were with NB 8.1). Thanks!


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo