Bug 269220 - java.util.MissingResourceException: bin/Linux-arm_64/libBuildTrace.so
java.util.MissingResourceException: bin/Linux-arm_64/libBuildTrace.so
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Project Discovery
8.2
All All
: P3 (vote)
: 8.2
Assigned To: Alexander Simon
issues@cnd
EXCEPTIONS_REPORT, 82patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-12-02 22:24 UTC by daiscog
Modified: 2016-12-08 11:45 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.01 KB, text/plain)
2016-12-02 22:24 UTC, daiscog
Details

Note You need to log in before you can comment on or make changes to this bug.
Description daiscog 2016-12-02 22:24:25 UTC
Build: NetBeans IDE 8.2 (Build 201609300101)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.111-b14, Java(TM) SE Runtime Environment, 1.8.0_111-b14
OS: Linux

User Comments:
daiscog: New C++ project with existing sources
   (simple project, three or four source files, plus makefile)
Select a Raspberry Pi as the build host
Click Finish
Exception is thrown at some point when the new project is created, possibly during the initial clean and build




Stacktrace: 
java.util.MissingResourceException: bin/Linux-arm_64/libBuildTrace.so
   at org.netbeans.modules.nativeexecution.api.util.HelperLibraryUtility.getLocalFileLocationFor(HelperLibraryUtility.java:237)
   at org.netbeans.modules.nativeexecution.api.util.HelperLibraryUtility.getPaths(HelperLibraryUtility.java:98)
   at org.netbeans.modules.nativeexecution.api.util.HelperLibraryUtility.getLibraryName(HelperLibraryUtility.java:191)
   at org.netbeans.modules.cnd.discovery.projectimport.ExecuteCommand.prepare(ExecuteCommand.java:221)
   at org.netbeans.modules.cnd.discovery.projectimport.ExecuteCommand.performAction(ExecuteCommand.java:110)
   at org.netbeans.modules.cnd.discovery.projectimport.ImportProject.postMake(ImportProject.java:1046)
Comment 1 daiscog 2016-12-02 22:24:27 UTC
Created attachment 163136 [details]
stacktrace
Comment 2 Alexander Simon 2016-12-04 11:38:32 UTC
Vladimir, as I remember you introduced Linux-arm architecture. It should not harm other subsystem.
How is it possible?
Comment 3 Vladimir Kvashin 2016-12-04 13:59:56 UTC
We'll get into the same situation for FreeBSD.

The problem is in incorrect processing of exception in 
cnd.discovery/src/org/netbeans/modules/cnd/discovery/projectimport/ExecuteCommand.java:225

HelperLibraryUtility.getLibraryName throws IOException when it can not find path (I don't like this approach, but we have what we have)

ExecuteCommand.prepare asks for path that can not be found. When it catches the IOExcepton, it should just understand that there is no such path, instead of reporting the exception via Exceptions.printStackTrace(ex);
Comment 4 Vladimir Kvashin 2016-12-04 14:02:17 UTC
Oh, sorry, I was wrong, it's not IOException (I erroneosly thought that MissingResourceException is an IOException). Investigatoing...
Comment 5 Vladimir Kvashin 2016-12-04 14:18:12 UTC
My previous comment was correct, MissingResourceException is wrapped into IOException, so we just need to fix error processing in ExecuteCommand.prepare.

Alexander, it will be more safe if you fix this, rather thn me, could you do this please>?
Comment 6 Alexander Simon 2016-12-05 09:26:31 UTC
It looks like a duplicate of the bug #268766
Comment 7 Alexander Simon 2016-12-05 09:29:19 UTC
fixed in enum, branch release82, change set 0f13018eaa7c
Comment 8 Quality Engineering 2016-12-08 02:37:04 UTC
Integrated into 'main-silver', will be available in build *201612080001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/1af9900dcefa
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #269220 java.util.MissingResourceException: bin/Linux-arm_64/libBuildTrace.so
(transplanted from 0f13018eaa7c3ef1d7c1f6f541da72a75dfe8f66)
Comment 9 soldatov 2016-12-08 11:45:05 UTC
Verified in internal NetBeans 8,2 patch 1 build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo