Bug 269170 - VCSOwnerTestCase constantly fails
VCSOwnerTestCase constantly fails
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Remote
Dev
All All
: P3 (vote)
: 8.2
Assigned To: Vladimir Kvashin
issues@cnd
82patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-11-29 19:18 UTC by Vladimir Kvashin
Modified: 2016-12-09 12:08 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Kvashin 2016-11-29 19:18:07 UTC
VCSOwnerTestCase fails many builds

java.lang.NullPointerException
	at org.netbeans.modules.versioning.VCSOwnerTestCase.testGetOwnerVersioned(VCSOwnerTestCase.java:105)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:497)
	at junit.framework.TestCase.runTest(TestCase.java:176)
	at org.netbeans.junit.NbTestCase.access$200(NbTestCase.java:102)
	at org.netbeans.junit.NbTestCase$2.doSomething(NbTestCase.java:478)
	at org.netbeans.junit.NbTestCase$1Guard.run(NbTestCase.java:404)
	at java.lang.Thread.run(Thread.java:745)

This is most likely caused by fixing of issue 268813 - There should be a provider for VCS forbidden folders + issue 268772 - Remote Versioning asks for /home/.hg and similar files
Comment 1 Vladimir Kvashin 2016-12-02 15:31:55 UTC
fixed in 152bb223c6c5 on enum/release82
Comment 2 Quality Engineering 2016-12-08 02:36:44 UTC
Integrated into 'main-silver', will be available in build *201612080001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/0b56da2d4016
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixed #269170 - VCSOwnerTestCase constantly fails
(transplanted from 152bb223c6c51b6a90accddb1b6d441c39b91c09)
Comment 3 petrk 2016-12-09 11:29:35 UTC
Verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo