Bug 269167 - Remote leaves warmup zip files (w/o ".zip" extension) in /tmp directory of the remote host
Remote leaves warmup zip files (w/o ".zip" extension) in /tmp directory of th...
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Remote
8.1
All All
: P3 (vote)
: 8.2
Assigned To: Vladimir Kvashin
issues@cnd
82patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-11-29 16:32 UTC by Vladimir Kvashin
Modified: 2016-12-09 12:14 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Kvashin 2016-11-29 16:32:39 UTC
Investigations of test failures showed that on some hosts there are a lot of files that contain zipped /usr/include.

Code shows that although such warmup files are removed in finally block, this does not always work if disconnect or other exception happens. This should be fixed via delete-on-exit.
Comment 1 Vladimir Kvashin 2016-11-29 17:53:06 UTC
see dlight.remote.impl/src/org/netbeans/modules/remote/impl/fs/RemoteFileZipper.java:223
Comment 2 Vladimir Kvashin 2016-11-29 20:16:10 UTC
fixed in change sets 71d3f2cf4ccb, ff06055f6d62 on enum/r82
Comment 3 Vladimir Kvashin 2016-12-01 17:06:01 UTC
After functional tests run, many files with names like rfs_warmup_XX2yuJWa.zip are left in remote host /tmp (sside-test-sparc). File size is usually 19366609 and it contains /usr/include.

The /usr/include is quite large on Solaris, when I tried to zip it from console, this took more than a minute.

I was able to reproduce the situation via pressing "red squire" button on remote tool bar while zip on remote site was running. 

Here are some technical details that show the reason. For some reason zip finished successfully (in spite of the fact that connection was lost). Since getting temp file name and zipping is done via a single script, and that script is run via ProcessUtils, IDE knows file name only after the script is complete. As the host is disconnected, it's too late to send "delete on exit" request
Comment 4 Vladimir Kvashin 2016-12-02 09:24:55 UTC
additional fix 7df46245c873 on enum/r82 fixes the issue
Comment 5 Quality Engineering 2016-12-03 03:03:35 UTC
Integrated into 'main-silver', will be available in build *201612030001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/a2bef237ed27
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixed #269167 - Remote leaves warmup zip files (w/o ".zip" extension) in /tmp directory of the remote host
(transplanted from 71d3f2cf4ccbd7075779d755a2272235f4cdfe0d)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo