Bug 269068 - [newcodemodel] AssertionError: Invalid index!
[newcodemodel] AssertionError: Invalid index!
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Code Model
Dev
All All
: P2 (vote)
: 8.2
Assigned To: Vladimir Voskresensky
issues@cnd
EXCEPTIONS_REPORT, 82patch1-verified
:
Depends on: 269115
Blocks:
  Show dependency treegraph
 
Reported: 2016-11-22 09:02 UTC by ashpynov
Modified: 2016-12-12 09:10 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.77 KB, text/plain)
2016-11-22 09:02 UTC, ashpynov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ashpynov 2016-11-22 09:02:55 UTC
Build: NetBeans IDE Dev (Build nbms-and-javadoc-595-on-20160906)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.60-b23, Java(TM) SE Runtime Environment, 1.8.0_60-b27
OS: Windows 7

User Comments:
ashpynov: .




Stacktrace: 
java.lang.AssertionError: Invalid index!
   at org.llvm.adt.StringRef.$at(StringRef.java:640)
   at org.llvm.support.sys.path.root_path(path.java:989)
   at org.clang.basic.FileManager.getDirectory(FileManager.java:368)
   at org.clang.basic.FileManager.getDirectory(FileManager.java:357)
   at org.clang.frontend.impl.InitHeaderSearch.AddUnmappedPath(InitHeaderSearch.java:145)
   at org.clang.frontend.impl.InitHeaderSearchClangGlobals.ApplyHeaderSearchOptions(InitHeaderSearchClangGlobals.java:73)
Comment 1 ashpynov 2016-11-22 09:02:57 UTC
Created attachment 162977 [details]
stacktrace
Comment 3 Quality Engineering 2016-12-03 03:03:45 UTC
Integrated into 'main-silver', will be available in build *201612030001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/dae4b9c565a1
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixing #269068 - [newcodemodel] AssertionError: Invalid index!
- trace to check for non-absolute paths
(transplanted from 00e6d5d2018d4605d995e8c346ce74cce549b632)
Comment 4 soldatov 2016-12-12 09:10:06 UTC
I can't reproduce this random exception in internal NetBeans 8,2 patch 1 build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo