Bug 268809 - java.util.ConcurrentModificationException at java.util.ArrayList$Itr.checkForComodification
java.util.ConcurrentModificationException at java.util.ArrayList$Itr.checkFor...
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Debugger
8.2
All All
: P3 (vote)
: 8.2
Assigned To: Maria Tishkova
issues@cnd
EXCEPTIONS_REPORT, 82patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-11-03 15:55 UTC by Exceptions Reporter
Modified: 2016-12-12 09:09 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.47 KB, text/plain)
2016-11-03 15:55 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2016-11-03 15:55:44 UTC
Build: NetBeans IDE 8.2 (Build 201609300101)
VM: OpenJDK 64-Bit Server VM, 25.112-b15, OpenJDK Runtime Environment, 1.8.0_112-b15
OS: Linux

User Comments:
GUEST: aa




Stacktrace: 
java.util.ConcurrentModificationException
   at java.util.ArrayList$Itr.checkForComodification(ArrayList.java:901)
   at java.util.ArrayList$Itr.next(ArrayList.java:851)
   at org.netbeans.modules.cnd.debugger.gdb2.GdbDebuggerImpl.retryWatches(GdbDebuggerImpl.java:3115)
   at org.netbeans.modules.cnd.debugger.gdb2.GdbDebuggerImpl.updateWatches(GdbDebuggerImpl.java:3128)
   at org.netbeans.modules.cnd.debugger.gdb2.GdbDebuggerImpl.genericStoppedWithSrc(GdbDebuggerImpl.java:3964)
   at org.netbeans.modules.cnd.debugger.gdb2.GdbDebuggerImpl.access$5900(GdbDebuggerImpl.java:150)
Comment 1 Exceptions Reporter 2016-11-03 15:55:46 UTC
Created attachment 162752 [details]
stacktrace
Comment 2 Maria Tishkova 2016-11-30 14:20:13 UTC
fixed in enum
changeset:   313506:e673aad62266
branch:      release82
tag:         tip
user:        Maria Dalmatova <mromashova@netbeans.org>
date:        Wed Nov 30 17:19:18 2016 +0300
summary:     fixed bz#268809 - java.util.ConcurrentModificationException at java.util.ArrayList$Itr.checkForComodification
Comment 3 Quality Engineering 2016-12-03 03:03:26 UTC
Integrated into 'main-silver', will be available in build *201612030001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/dc050bb40e71
User: Maria Dalmatova <mromashova@netbeans.org>
Log: fixed bz#268809 - java.util.ConcurrentModificationException at java.util.ArrayList$Itr.checkForComodification
(transplanted from e673aad622667ac1b99da7af1a6c1344eb1fae30)
Comment 4 soldatov 2016-12-12 09:09:11 UTC
I can't reproduce this random exception in internal NetBeans 8,2 patch 1 build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo