Bug 268788 - org.netbeans.modules.deadlock.detector.Detector$DeadlockDetectedException: SFTP: : Uploading C:\Program Files\NetBeans 8.1\cnd\bin\Linux-x86\rfs_controller to max.grachev@135.247.194.83:/var/tmp/dligh
org.netbeans.modules.deadlock.detector.Detector$DeadlockDetectedException: SF...
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: execution
8.1
All All
: P3 (vote)
: 8.2
Assigned To: ilia
issues@cnd
EXCEPTIONS_REPORT, 82patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-11-02 11:46 UTC by Exceptions Reporter
Modified: 2016-12-12 09:08 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (6.66 KB, text/plain)
2016-11-02 11:46 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2016-11-02 11:46:43 UTC
Build: NetBeans IDE 8.1 (Build 201510222201)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.31-b07, Java(TM) SE Runtime Environment, 1.8.0_31-b13
OS: Windows 7

User Comments:
GUEST: Apply Look and Feel -> reload application




Stacktrace: 
org.netbeans.modules.deadlock.detector.Detector$DeadlockDetectedException: SFTP: : Uploading C:\Program Files\NetBeans 8.1\cnd\bin\Linux-x86\rfs_controller to max.grachev@135.247.194.83:/var/tmp/dlight_max.grachev/bb5ca9d5/tools/Linux-x86/rfs_controller
   at org.netbeans.modules.nativeexecution.api.util.HostInfoUtils.getHostInfo(HostInfoUtils.java:273)
   at org.netbeans.modules.nativeexecution.api.util.HostInfoUtils.getHostInfo(HostInfoUtils.java:255)
   at org.netbeans.modules.nativeexecution.api.util.HelperUtility.getPath(HelperUtility.java:142)
   at org.netbeans.modules.nativeexecution.api.util.HelperUtility.getPath(HelperUtility.java:104)
   at org.netbeans.modules.nativeexecution.NbNativeProcess.<init>(NbNativeProcess.java:81)
   at org.netbeans.modules.nativeexecution.NbRemoteNativeProcess.<init>(NbRemoteNativeProcess.java:57)
Comment 1 Exceptions Reporter 2016-11-02 11:46:45 UTC
Created attachment 162728 [details]
stacktrace
Comment 2 ilia 2016-11-07 07:46:12 UTC
This bug is related to https://netbeans.org/bugzilla/show_bug.cgi?id=267378
Both have the same threading problem.
Comment 3 Quality Engineering 2016-11-16 02:51:16 UTC
Integrated into 'main-silver', will be available in build *201611160001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/44916a800882
User: Ilia Gromov <ilia@netbeans.org>
Log: fixed #268788 - org.netbeans.modules.deadlock.detector.Detector$DeadlockDetectedException: SFTP: : Uploading C:\Program...
(transplanted from 5de260f4c13663367b6c3ab556157c710a966b23)
Comment 4 soldatov 2016-12-12 09:08:42 UTC
I can't reproduce this random exception in internal NetBeans 8,2 patch 1 build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo