Bug 268785 - 8.2 breaks multi-pane navigation
8.2 breaks multi-pane navigation
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Painting & Printing
8.2
PC Linux
: P1 (vote)
: 8.2
Assigned To: Miloslav Metelka
issues@editor
82patch1-verified
:
: 269151 269166 (view as bug list)
Depends on:
Blocks: 269151
  Show dependency treegraph
 
Reported: 2016-11-02 10:34 UTC by naquada
Modified: 2016-12-13 13:14 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description naquada 2016-11-02 10:34:10 UTC
When using multiple panes in an editor (dragging the sash at the top of the window to split it horizontally or vertically), *all* the panes get scrolled to the caret when inserting text.  This makes the multi-pane functionality useless.  The whole purpose of multi-pane is to view/edit at multiple locations in the same buffer. A pane should not scroll unless I delete/insert text in the region that it is displaying.
Comment 1 naquada 2016-11-02 10:45:01 UTC
This problem extends beyond just multiple panes.  The scrolling happens even in "clones" of the editor buffer for a given file.  

It is now impossible to edit at two different locations in the same file, or even view at a different location than you're currently editing.  

This is a very serious problem.
Comment 2 naquada 2016-11-02 10:47:12 UTC
Product Version: NetBeans IDE 8.2 (Build 201609300101)
Java: 1.8.0_74; Java HotSpot(TM) 64-Bit Server VM 25.74-b02
Runtime: Java(TM) SE Runtime Environment 1.8.0_74-b02
System: Linux version 4.4.6-300.fc23.x86_64 running on amd64; UTF-8; en_US (nb)
Comment 3 Milutin Kristofic 2016-11-02 13:17:46 UTC
Mila, does this happen because of multicaret implementation?
Comment 4 Miloslav Metelka 2016-11-22 11:29:10 UTC
Yes, I'll fix it.
Comment 5 Miloslav Metelka 2016-11-22 15:14:29 UTC
http://hg.netbeans.org/jet-main/rev/e0b816b82141
Comment 6 Quality Engineering 2016-11-24 02:53:39 UTC
Integrated into 'main-silver', will be available in build *201611240001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/e0b816b82141
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #268785 - 8.2 breaks multi-pane navigation.
Comment 7 Miloslav Metelka 2016-12-05 15:08:58 UTC
Since the original fix caused regressions such as issue #269151 I've refined the original fix:
http://hg.netbeans.org/jet-main/rev/5ece8b9b81cb
Comment 8 Miloslav Metelka 2016-12-05 15:16:05 UTC
*** Bug 269151 has been marked as a duplicate of this bug. ***
Comment 9 Miloslav Metelka 2016-12-05 15:19:05 UTC
*** Bug 269166 has been marked as a duplicate of this bug. ***
Comment 10 Quality Engineering 2016-12-07 02:40:04 UTC
Integrated into 'main-silver', will be available in build *201612070001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/5ece8b9b81cb
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #268785 - 8.2 breaks multi-pane navigation - refined patch to avoid regressions.
Comment 11 Vladimir Voskresensky 2016-12-07 09:36:29 UTC
Mila, I think there is still a regression with cursor/focus:
open any java file to have cursor in it
press ctrl+7 to activate navigator
type any method name part and when navigator focus on the method press Enter
press UP/DOWN
Expected:
cursor is in editor on the selected method
Now:
cursor is still in navigator
Comment 12 Miloslav Metelka 2016-12-08 09:12:40 UTC
Vladimir, I don't think it's caused by this patch. When I go through your steps I see a floating field pops up where the method name gets entered. After pressing Enter the focus goes from this field to the navigator. If I press Enter the second time the focus finally goes to the editor. So imho the problem might be more in the navigator than the editor. Anyway it should imho be tracked by a separate issue. I've filed issue #269268.
Comment 13 Miloslav Metelka 2016-12-09 23:21:47 UTC
Transplanted into release82:
e0b816b82141 transplanted to ff3decac011d
5ece8b9b81cb transplanted to 5d02f0d0528f
Comment 14 Jiri Prox 2016-12-13 13:14:11 UTC
verified in patch


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo