Bug 268742 - Deadlock on opening a project
Deadlock on opening a project
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Painting & Printing
Dev
PC Other
: P2 (vote)
: TBD
Assigned To: Miloslav Metelka
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-10-30 09:34 UTC by cezariusz
Modified: 2016-11-05 12:01 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (36.49 KB, text/plain)
2016-10-30 09:34 UTC, cezariusz
Details
messages.log (70.46 KB, application/octet-stream)
2016-10-30 09:37 UTC, cezariusz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cezariusz 2016-10-30 09:34:28 UTC
Build 201609280002

One of my small projects makes NetBeans to deadlock on startup. The IDE doesn't respond to anything, cannot close it, have to kill the process.
Comment 1 cezariusz 2016-10-30 09:34:57 UTC
Created attachment 162685 [details]
Thread dump
Comment 2 cezariusz 2016-10-30 09:37:47 UTC
Created attachment 162686 [details]
messages.log

The project name is "Cotr".
Comment 3 cezariusz 2016-10-30 09:38:52 UTC
Deadlock -> P2.
Comment 4 cezariusz 2016-10-30 17:43:31 UTC
Same with the current dev:

Product Version: NetBeans IDE Dev (Build 201610260002)
Java: 1.8.0_60; Java HotSpot(TM) 64-Bit Server VM 25.60-b23
Runtime: Java(TM) SE Runtime Environment 1.8.0_60-b27
System: Windows 10 version 10.0 running on amd64; Cp1250; pl_PL (nb)
Comment 5 Tomas Hurka 2016-10-31 14:47:17 UTC
This looks like deadlock in editor.
Comment 6 Jiri Kovalsky 2016-10-31 14:59:38 UTC
Cezariusz, is there a chance for you to share with us the project privately or at least its structure? Ideally a sample project with the same setup reproducing the problem. Thanks!
Comment 7 cezariusz 2016-10-31 16:03:56 UTC
(In reply to Jiri Kovalsky from comment #6)
> Cezariusz, is there a chance for you to share with us the project privately
> or at least its structure? Ideally a sample project with the same setup
> reproducing the problem. Thanks!

I have created a new project group, opened the project causing the dead lock and it worked properly, so it's not related to that particular project. Actually it's a very simple ANT project with only one class file. So the problem might be related to the project group, with consist of many project of various types including Java Ant, Java Maven, NetBeans Module, NetBeans Suite, Web Ant, and C/C++. It's close to impossible to share all project from that group.
Comment 8 cezariusz 2016-10-31 16:08:26 UTC
Previously I've been using the debugger on that project and I've pinned some variables. It might be related if pinned variables are stored somewhere in the project group.
Comment 9 cezariusz 2016-11-05 12:01:26 UTC
Fixed by:
http://hg.netbeans.org/jet-main/rev/7a7819654f2c


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo