Bug 268142 - macOS upgrade from OS 10.11 (el Capitan) causes issue with include files missing from C++ IDE.
macOS upgrade from OS 10.11 (el Capitan) causes issue with include files miss...
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Code Model
8.2
Macintosh Mac OS X
: P2 (vote)
: Dev
Assigned To: issues@cnd
issues@cnd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-21 15:36 UTC by omossafa
Modified: 2016-09-30 23:36 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (211.75 KB, text/plain)
2016-09-21 15:37 UTC, omossafa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description omossafa 2016-09-21 15:36:41 UTC
Product Version = NetBeans IDE 8.2 RC (Build 201609140952)
Operating System = Mac OS X version 10.12 running on x86_64
Java; VM; Vendor = 1.8.0_92
Runtime = Java HotSpot(TM) 64-Bit Server VM 25.92-b14

Reproducibility: Happens every time

STEPS:
  * Open dialog Foo
  * Click on button "Click me"
C++ IDE seems to either be missing necessary standard files or can't see them since OS update to macOS from El Capitan.
ACTUAL:
  nothing happens
Each of my C++ Applications has small '?' in each icon, and I get red error points everywhere starting from '#include' & 'using' calls at top of each main class. My only thinking is this is because of the OS upgrade, some special call to these files had issues, or they were somehow in a folder not accessible in this upgrade of the OS. I tried reinstalling 2 times, once with v8.1 and once with v.8.2RC, but all seem to unable to access these standard files. I hope this uprade doesn't kill this great IDE.
EXPECTED:
  Nothing would change, but missing standard files is essential for IDE to properly compile.
Comment 1 omossafa 2016-09-21 15:37:16 UTC
Created attachment 162159 [details]
IDE log
Comment 2 Alexander Simon 2016-09-22 07:43:43 UTC
It seem a root cause is the same as in the bug #268144.
Please verify.
Comment 3 omossafa 2016-09-22 15:20:01 UTC
Problem seemed to have resolved once I installed Xcode 8 and opened the developer app.  It must have triggered the missing/hidden standard c/c++ file folder Netbeans could not find or install properly.  I can't say hy or how this exactly resolved, but that after upgrading to macOS and Netbeans v8.1 noting not able to find folder with standard files (#include files or namespace file), the Xcode install and app opening (I am not sure if just the install triggered access to missing folder, or needing to start up the app too, so I suggest starting it up to be sure, or go step by step to see where the access for Netbeans is resolved).
Comment 4 Vladimir Voskresensky 2016-09-30 23:36:30 UTC
Thanks for the information. And yes, installing XCode package installs some folders with headers. So it could be the reason


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo