Bug 267371 - Qt projects fail to build on OS X
Qt projects fail to build on OS X
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Project
8.2
Macintosh Mac OS X
: P2 (vote)
: 8.2
Assigned To: Vladimir Kvashin
issues@cnd
82patch2-verified
: REGRESSION
: 270510 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-08-01 00:30 UTC by rwhartzell
Modified: 2017-04-30 15:55 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rwhartzell 2016-08-01 00:30:09 UTC
Netbeans generated *.pro file has a bad LIB line and its generated even if no other libraries are included.

example: (LIB += . . . . . . . .)

The above series of dots is always appended in the generated *.pro file in QT projects including the sample project. This causes the linker to fail with: 

ld: can't map file, errno=22 file '.' for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[2]: *** [dist/Debug/Qt5.6-MacOSX/HelloQtWorld] Error 1
make[1]: *** [.build-conf] Error 2
make: *** [.build-impl] Error 2

BUILD FAILED (exit value 2, total time: 7s)

 
The seems to be a regression that was probably introduced in early June 2016 but I don't have access to the builds to pin point exactly which nightly build. It's not present in 8.1 and only effects OS X.
Comment 1 Alexander Simon 2016-08-22 10:54:33 UTC
regression after fixing bug #255959
Comment 2 Vladimir Kvashin 2017-04-10 10:53:46 UTC
fixed, change set cc35fe009918 on enum
Comment 3 ilia 2017-04-13 10:34:31 UTC
https://netbeans.org/bugzilla/show_bug.cgi?id=267371 Changesets:
    http://hg.netbeans.org/releases/rev/cc35fe009918 # fixed #267371 - Qt projects fail to build on OS X
Comment 4 Quality Engineering 2017-04-14 01:53:56 UTC
Integrated into 'main-silver', will be available in build *201704140002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/17968a094bfa
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixed #267371 - Qt projects fail to build on OS X
(transplanted from cc35fe00991853ab8a912ee29e0698f37eef3816)
Comment 5 soldatov 2017-04-20 13:27:45 UTC
Verified in NetBeans IDE 8.2 (Build 201704181436)
Comment 6 Vladimir Kvashin 2017-04-30 15:55:08 UTC
*** Bug 270510 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo