Bug 26411 - Installer froze Xwindow
Installer froze Xwindow
Status: CLOSED FIXED
Product: installer
Classification: Unclassified
Component: Code
3.x
Sun Solaris
: P1 (vote)
: 3.x
Assigned To: Richard Gregor
issues@installer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-09 11:10 UTC by pknakal
Modified: 2003-07-01 09:47 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
panel image (28.68 KB, image/png)
2002-08-09 11:17 UTC, pknakal
Details
thread dump (4.00 KB, text/plain)
2002-08-12 15:25 UTC, Filip Rachunek
Details
diff of changes in trunk (1.89 KB, patch)
2002-08-19 14:29 UTC, Richard Gregor
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description pknakal 2002-08-09 11:10:35 UTC
Solaris 8, CDE, NB Installer 200208082340
How to reproduce:
1) there must exists .netbeans directory with, at
minimum, one userdir of NetBeans
2) start installer
3) next in welcome panel
4) in the next pannel select ImportSettings and
click to combo box ... now the Xsession is frozen

How to repair
login form remote (telnet) computer and kill
Xsession or all java processes
Comment 1 pknakal 2002-08-09 11:17:27 UTC
Created attachment 7070 [details]
panel image
Comment 2 pknakal 2002-08-09 11:48:47 UTC
Same problem on Linux. This is only JDK1.3.x problem.
Comment 3 Filip Rachunek 2002-08-12 15:25:17 UTC
Created attachment 7084 [details]
thread dump
Comment 4 Richard Gregor 2002-08-19 14:27:01 UTC
This problem is caused by choice component. When the state of this
component is changed then X Window is frozen.There is probably problem
with event dispatch - choice component is InstallShield's own component.
Comment 5 Richard Gregor 2002-08-19 14:29:42 UTC
Created attachment 7128 [details]
diff of changes in trunk
Comment 6 Richard Gregor 2002-08-19 14:31:50 UTC
Fixed.
Comment 7 Filip Rachunek 2002-08-19 15:04:56 UTC
Verified the patch, it looks okay, no major code changes.
Comment 8 Jesse Glick 2002-08-19 18:23:16 UTC
Please alert nbdev to this issue, as we are after RC2 and all changes
should get wide attention.
Comment 9 pknakal 2002-08-20 10:27:44 UTC
Verified. Works OK.
Comment 10 Richard Gregor 2002-08-21 07:05:43 UTC
Fixed in release34.
Comment 11 Quality Engineering 2003-07-01 09:47:02 UTC
Resolved for 3.4 or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo