Bug 262709 - NullPointerException at org.netbeans.modules.cnd.remote.sync.FtpSyncWorker.uploadPlainFilesInZip
NullPointerException at org.netbeans.modules.cnd.remote.sync.FtpSyncWorker.up...
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Remote
8.1
All All
: P3 (vote)
: 8.2
Assigned To: Vladimir Kvashin
issues@cnd
EXCEPTIONS_REPORT, 82patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-07-07 08:22 UTC by Exceptions Reporter
Modified: 2016-12-12 09:04 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (874 bytes, text/plain)
2016-07-07 08:22 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2016-07-07 08:22:03 UTC
Build: NetBeans IDE 8.1 (Build 201510222201)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.51-b03, Java(TM) SE Runtime Environment, 1.8.0_51-b16
OS: Windows 8

User Comments:
GUEST: Upload to host canceled




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.cnd.remote.sync.FtpSyncWorker.uploadPlainFilesInZip(FtpSyncWorker.java:724)
   at org.netbeans.modules.cnd.remote.sync.FtpSyncWorker.synchronizeImpl(FtpSyncWorker.java:230)
   at org.netbeans.modules.cnd.remote.sync.FtpSyncWorker.startup(FtpSyncWorker.java:782)
   at org.netbeans.modules.cnd.remote.sync.RemoteBuildProjectActionHandler.execute(RemoteBuildProjectActionHandler.java:180)
   at org.netbeans.modules.cnd.makeproject.api.ProjectActionSupport$EventsProcessor.run(ProjectActionSupport.java:598)
   at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1443)
Comment 1 Exceptions Reporter 2016-07-07 08:22:05 UTC
Created attachment 160292 [details]
stacktrace
Comment 2 Vladimir Kvashin 2016-10-07 12:04:41 UTC
fixed on enum:
d3bc334ddab3
368fba58744f
Comment 3 Quality Engineering 2016-10-20 01:59:11 UTC
Integrated into 'main-silver', will be available in build *201610200002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/03d609695523
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixing #262709 - NullPointerException at org.netbeans.modules.cnd.remote.sync.FtpSyncWorker.uploadPlainFilesInZip
(transplanted from 368fba58744f4e7f677c458d7c17de21b5ae1120)
Comment 4 soldatov 2016-12-12 09:04:43 UTC
I can't reproduce this random exception in internal NetBeans 8,2 patch 1 build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo