Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 26208 - Move org.netbeans.core.ui.Module{Bean,Node} to AU
Move org.netbeans.core.ui.Module{Bean,Node} to AU
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Autoupdate
3.x
All All
: P3 (vote)
: 5.x
Assigned To: Jiri Rechtacek
issues@platform
NbFeature1037
: API_REVIEW_FAST
Depends on: 26214
Blocks: 26064
  Show dependency treegraph
 
Reported: 2002-08-02 09:00 UTC by akemr
Modified: 2005-09-05 09:52 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description akemr 2002-08-02 09:00:12 UTC
Situation: On IDE start (after upgrade), module
system will detect not-satisfied module dependency
(caused by changed API,
and missing emulator) it will be nice if AU then
will look for new version of module on available
Update Centers.

For this reason
org.netbeans.core.ui.Module{Bean,Node} should be
moved to autoupdate.jar
Comment 1 akemr 2002-09-18 14:36:46 UTC
I investigated and found that together with moving ModuleNode and
ModuleBean following should be done:

1. Move ModuleEnableDisablePanel
2. Move (or delete?) SetupWizard and ModuleSelectionPanel
3. Move "Modules part" from core/ui/resources/layer.xml to AU layer.

Anyway, these parts depends on core.modules.* (Module, ModuleManager,
ModuleHistory..).
So, I guess this issue depends on #26214 (Create
org.netbeans.[as]pi.modules)
Comment 2 akemr 2002-09-24 10:40:45 UTC
Decreasing priority because of dependency on #26214 (P3)
Comment 3 Marian Mirilovic 2002-12-06 18:50:34 UTC
reassigne to Hrebejk, new owner of autupdate 
Comment 4 Marian Mirilovic 2003-12-01 10:48:59 UTC
reassigne to Jirka - new owner of autoupdate
Comment 5 Marian Mirilovic 2004-12-23 10:28:19 UTC
Is this still valid issue ?
Comment 6 Jesse Glick 2004-12-23 16:25:15 UTC
Probably still valid.
Comment 7 Jiri Rechtacek 2005-04-26 15:00:08 UTC
Merge Module Catalog and Autoupdate UI is planned for NB4.2.
Comment 8 Jiri Rechtacek 2005-07-21 16:40:04 UTC
Autoupdate suggests itself as a logically unit to all manipulation of modules:
adding, disabling/enabling, removing.
Autoupdate currently does adding, issue 20323 - Remove a module is almost done,
this functionality offers also AU. The Module Catalog for viewing and
enable/disable of modules unifies this manipulation instead of SetupWizard and
Option dialog. In the light of these facts I propose to move Module Catalog with
all corresponding classes from Core module to AU. It doesn't ask any API change,
all works within current APIs, in addition to a friend API between AU and Core
becomes useless.

This means: ModuleBean, ModuleNode, ModuleDisableEnablePanel,
ModuleSelectionPanel, ModuleCatalogAction etc. will be moved from core/src/../ui
to autoupdate/src/../catalog and layers will be changed by these replacement.

All planned changes are implemented on the branch uninstall_module_20323 across
modules Core, Core-UI and Autoupdate.

Thanks for review planned changes.

Thanks for review
Comment 9 Jesse Glick 2005-07-21 16:55:30 UTC
Don't forgot to remove the ancient org.netbeans.core.ModuleNode.
Comment 10 Jaroslav Tulach 2005-07-21 17:44:07 UTC
Also there is some friend extension between core and autoupdate to support new 
module from NBM: 
http://www.netbeans.org/download/dev/javadoc/org-netbeans-modules-autoupdate/architecture-summary.html#java-org.netbeans.core.ModuleNode.ModuleNewType 
please update the arch documents in core and autoupdate. 
Comment 11 Jiri Rechtacek 2005-07-29 09:14:00 UTC
Thanks for review. Recommendation already done in a branch. I'm going to
integrate early next week.
Comment 12 Jiri Rechtacek 2005-08-03 15:12:17 UTC
Impl has been integrated in main trunk 05/08/03.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo