Bug 259002 - [newcodemodel] AssertionError: Path should be absolute: StringRef{\\ALEX-PC\Users\alex\CppApplication_2\main.cpp}
[newcodemodel] AssertionError: Path should be absolute: StringRef{\\ALEX-PC\U...
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Code Model
8.2
All All
: P2 (vote)
: 8.2
Assigned To: Vladimir Kvashin
issues@cnd
EXCEPTIONS_REPORT
:
: 259001 259003 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-04-25 09:27 UTC by Alexander Simon
Modified: 2016-09-09 01:53 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (6.35 KB, text/plain)
2016-04-25 09:27 UTC, Alexander Simon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Simon 2016-04-25 09:27:15 UTC
This bug was originally marked as duplicate of bug 254496, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 20160425-0b8d17bee7c7)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.74-b02, Java(TM) SE Runtime Environment, 1.8.0_74-b02
OS: Windows 7

User Comments:
alexvsimon: start editing C++ file

alexvsimon: Edit C++ file




Stacktrace: 
java.lang.AssertionError: Path should be absolute: StringRef{\\ALEX-PC\Users\alex\CppApplication_2\main.cpp}
   at org.clang.tools.services.impl.PreprocessorInitializer.clearFileCache(PreprocessorInitializer.java:159)
   at org.clang.tools.services.ClankPreprocessorServices.invalidate(ClankPreprocessorServices.java:75)
   at org.netbeans.modules.cnd.apt.impl.support.clank.ClankDriverImpl.invalidateImpl(ClankDriverImpl.java:89)
   at org.netbeans.modules.cnd.apt.impl.support.clank.ClankDriverImpl.invalidateImpl(ClankDriverImpl.java:96)
   at org.netbeans.modules.cnd.apt.support.ClankDriver.invalidate(ClankDriver.java:286)
   at org.netbeans.modules.cnd.modelimpl.csm.core.ProjectBaseWithEditing.onFileEditStart(ProjectBaseWithEditing.java:96)
Comment 1 Alexander Simon 2016-04-25 09:27:16 UTC
Created attachment 159422 [details]
stacktrace
Comment 2 Vladimir Voskresensky 2016-04-25 11:49:20 UTC
*** Bug 259001 has been marked as a duplicate of this bug. ***
Comment 3 Vladimir Voskresensky 2016-04-25 11:49:25 UTC
*** Bug 259003 has been marked as a duplicate of this bug. ***
Comment 4 Vladimir Kvashin 2016-09-07 09:50:00 UTC
Another related stack is

java.lang.AssertionError: Path should be absolute: StringRef{\\vboxsrv}
	at org.clang.tools.services.impl.PreprocessorInitializer.clearFileCache(PreprocessorInitializer.java:160)
	at org.clang.tools.services.ClankPreprocessorServices.invalidate(ClankPreprocessorServices.java:75)
	at org.netbeans.modules.cnd.apt.impl.support.clank.ClankDriverImpl.invalidateImpl(ClankDriverImpl.java:89)
	at org.netbeans.modules.cnd.apt.impl.support.clank.FileExistsSensitiveClankCacheDriver.invalidateFile(FileExistsSensitiveClankCacheDriver.java:67)
	at org.netbeans.modules.cnd.utils.cache.CndFileUtils$FSListener.invalidateFile(CndFileUtils.java:888)
	at org.netbeans.modules.cnd.utils.cache.CndFileUtils$FSListener.cleanCachesImpl(CndFileUtils.java:901)
	at org.netbeans.modules.cnd.utils.cache.CndFileUtils$FSListener.fileDeleted(CndFileUtils.java:834)
	at org.openide.filesystems.FCLSupport$DispatchEventWrapper.dispatchEventImpl(FCLSupport.java:181)
	at org.openide.filesystems.FCLSupport$DispatchEventWrapperMulti.dispatchAllEventsSync(FCLSupport.java:248)
	at org.openide.filesystems.FCLSupport$DispatchEventWrapper.dispatchEvent(FCLSupport.java:137)
	at org.openide.filesystems.FCLSupport$1.run(FCLSupport.java:261)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1443)
	at org.netbeans.modules.openide.util.GlobalLookup.execute(GlobalLookup.java:68)
	at org.openide.util.lookup.Lookups.executeWith(Lookups.java:303)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2058)
Caused: org.openide.util.RequestProcessor$FastItem: task failed due to
Comment 5 Vladimir Kvashin 2016-09-07 09:51:22 UTC
(In reply to Vladimir Kvashin from comment #4)
> Another related stack is...
what's funny about that is that it appears when I just opened a "Open Project" file chooser and entered "\\vboxsrv\" there
Comment 6 Vladimir Kvashin 2016-09-07 18:43:12 UTC
fixed
http://hg.netbeans.org/cnd-main/rev/5b1c3ea3bd97
sputnik~main/rev/256e2aaef21f
Comment 7 Quality Engineering 2016-09-09 01:53:06 UTC
Integrated into 'main-silver', will be available in build *201609090002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/5b1c3ea3bd97
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: updated binaries after fixing #259002 - [newcodemodel] AssertionError: Path should be absolute: StringRef{\\ALEX-PC\Users\alex\CppApplication_2\main.cpp


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo