Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 255923 - Please add an option to show the created sql for a table
Please add an option to show the created sql for a table
Status: RESOLVED DUPLICATE of bug 154177
Product: db
Classification: Unclassified
Component: DB schema
8.1
PC Other
: P3 (vote)
: TBD
Assigned To: Libor Fischmeistr
issues@db
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 12:49 UTC by ChrisLE
Modified: 2017-01-08 11:24 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ChrisLE 2015-10-14 12:49:51 UTC
When I insert a new record to a table, I have the option "show SQL", above the visual stuff, I can see my sql "INSERT INTO....". This option is really needed for creating a table too. That I can copy it inside the visual stuff where I can create a new table. It should be also available for functions and views too.


Regards

Chris

P.S. Here you can see an example how 0xDBE does it from JetBrains:
https://confluence.jetbrains.com/display/DBE/0xDBE+143.109+Released
Comment 1 ChrisLE 2015-10-14 12:54:53 UTC
forget it for functions and view, because I think it doesn't make sense in this context. So only or tables.
Comment 2 ChrisLE 2015-10-14 12:55:14 UTC
only FOR tables I mean.
Comment 3 ChrisLE 2016-12-31 01:47:31 UTC
I'm working on a feature to show the SQL for a table when you right click on it and choose "View DDL/SQL". Then you got a little dialog, like the ShowSQLDialog where your Create Table SQL statement is inside. This is not sooo related to this bug but it helps to grab the structure without using "grab structure" save the file, and recreate a table to got the sql.
Comment 4 matthias42 2017-01-08 11:24:56 UTC

*** This bug has been marked as a duplicate of bug 154177 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo