Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 254086 - [81cat] Profiling WilfFly fails
[81cat] Profiling WilfFly fails
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: WildFly
8.1
PC Windows 8
: P3 (vote)
: 8.1
Assigned To: ehsavoie
issues@javaee
:
: 253480 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-02 20:36 UTC by muellermi
Modified: 2015-10-21 09:03 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (74.34 KB, text/plain)
2015-08-02 20:36 UTC, muellermi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description muellermi 2015-08-02 20:36:28 UTC
Product Version = NetBeans IDE 8.1 Beta (Build 201507302201)
Operating System = Windows 8 version 6.2 running on amd64
Java; VM; Vendor = 1.8.0_51
Runtime = Java HotSpot(TM) 64-Bit Server VM 25.51-b03

- create new web app, using wildfly
- choose profile
- start profiling

NB tries to attach to the target VM forever...
(Profiling a GlassFish web app works fine)

ant -f D:\\Dokumente\\NetBeansProjects\\WebApplication3 -Dnb.internal.action.name=profile -Ddirectory.deployment.supported=false -DforceRedeploy=false -Dnb.wait.for.caches=true "-Drun.jvmargs.ide= -agentpath:\"C:/Program Files/NetBeans 8.1 Beta/profiler/lib/deployed/jdk16/windows-amd64/profilerinterface.dll\"=\"C:\\Program Files\\NetBeans 8.1 Beta\\profiler\\lib\",5140,10 -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=D:\\Dokumente\\NetBeansProjects\\WebApplication3\\nbproject\\private\\profiler " -Dbrowser.context=D:\\Dokumente\\NetBeansProjects\\WebApplication3 profile
profile:
init:
deps-module-jar:
deps-ear-jar:
deps-jar:
library-inclusion-in-archive:
library-inclusion-in-manifest:
compile:
compile-jsps:
Starting WildFly Application Server for profiling
Starting WildFly Application Server
WildFly Application Server Start Failed
D:\Dokumente\NetBeansProjects\WebApplication3\nbproject\build-impl.xml:1275: The following error occurred while executing this line:
D:\Dokumente\NetBeansProjects\WebApplication3\nbproject\build-impl.xml:1268: WildFly Application Server Start Failed
BUILD FAILED (total time: 22 seconds)
Comment 1 muellermi 2015-08-02 20:36:34 UTC
Created attachment 155129 [details]
IDE log
Comment 2 ehsavoie 2015-08-07 12:42:56 UTC
Profiling doesn't work with WildFly currently because of an issue with jboss-logging
Comment 3 ehsavoie 2015-09-23 12:43:26 UTC
*** Bug 253480 has been marked as a duplicate of this bug. ***
Comment 4 ehsavoie 2015-10-21 09:03:12 UTC
Should be fixed with 0dcb6f0664cf


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo