Bug 25286 - warning message printed when exec'ing runide.sh from a working directory with spaces in path
warning message printed when exec'ing runide.sh from a working directory with...
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
3.x
Sun Solaris
: P2 (vote)
: TBD
Assigned To: _ ttran
issues@platform
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-28 20:27 UTC by _ hlu
Modified: 2008-12-23 12:55 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ hlu 2002-06-28 20:27:26 UTC
NetBeans3.4 Beta(build 200206201555):

The default install directory is "NetBeans IDE
3.4beta". Notice, there are spaces in that. When I
ran ide installed in the default directory using
"runide.sh", the ide could not start with error
message:
./runide.sh: /ffj/NetBeans: does not exist

Installing ide in directory without space, ide
will run.
Comment 1 Richard Gregor 2002-07-01 16:38:37 UTC
Since NB3.3.1 ide could use spaces in names. So installer allows this
kind of install directory. Similar message is shown on Linux: 
sh-2.04$ ./runide.sh 
./runide.sh: cd: /usr/java/NetBeans: No such file or directory

But on Linux ide will start. It doesn't look to be issue for
installer. I'm reasignig it to core because it is in runide.sh.
Comment 2 _ ttran 2002-07-01 17:03:50 UTC
strange.  Last time I checked it worked fine.   Will look at this again
Comment 3 _ ttran 2002-07-02 08:58:33 UTC
I found missing quotes in the runide.sh.  The warning message is
printed but the IDE is launched okay (mine == Linux).

The problem is not the installation directory but rather the current
working directory (which happens to be the install dir in your case)
with spaces in path.

Updated the "Summary" field accordingly.
Comment 4 _ ttran 2002-07-02 09:00:16 UTC
fixed
Comment 5 _ ttran 2002-07-12 12:51:09 UTC
sync'ed runide.sh in sierra branch to rev 1.36, thus fixed this bug
for S1S 4.1
Comment 6 Marian Mirilovic 2002-09-05 18:00:31 UTC
verified in nb3.4
Comment 7 Marian Mirilovic 2002-09-05 18:05:47 UTC
verified in s1s 4.1 (020901)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo