Bug 25268 - [MDI] Source Editor is restored when opening new project
[MDI] Source Editor is restored when opening new project
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC Linux
: P3 (vote)
: 3.x
Assigned To: mslama
issues@platform
:
: 25169 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-28 13:18 UTC by mslama
Modified: 2008-12-23 09:38 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mslama 2002-06-28 13:18:47 UTC
Welcome.wstcref and editor.wsmode is now in global
layer. So Source Editor is kept open when new
project is created. But it should stay maximized.
Comment 1 mslama 2002-07-01 12:45:23 UTC
Fixed in main trunk. Current frame state for mode is now stored. Also
restored frame state is stored when frame state is maximized. New DTD
for wsmode was added. Also editor.wsmode was changed in core-ui and
welcome module.

Modified:
core/src/org/netbeans/core/windows/ModeImpl.java r.1.148
core/src/org/netbeans/core/windows/layers/ModeData.java r.1.88
Comment 2 mslama 2002-07-01 17:18:10 UTC
*** Issue 25169 has been marked as a duplicate of this issue. ***
Comment 3 Marian Mirilovic 2002-07-09 10:38:23 UTC
verified in [nb_dev](20020709)
Comment 4 Quality Engineering 2003-07-01 16:41:52 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo