Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 249458 - Integrate git stashes with shelve changes
Integrate git stashes with shelve changes
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Git
8.1
PC Linux
: P3 (vote)
: 8.1
Assigned To: Ondrej Vrabec
issues@versioncontrol
:
Depends on: 224986
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-19 14:22 UTC by Ondrej Vrabec
Modified: 2015-01-13 04:17 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
IDE log (71.24 KB, text/plain)
2014-12-19 14:23 UTC, Ondrej Vrabec
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ondrej Vrabec 2014-12-19 14:22:52 UTC
Primarily shelve changes should be built on top of git stashes and git stash in repository view could list also other shelve-sets generated on top of the repository.

I suppose Shelve changes should open git stash create view and allow to delegate to the current shelve changes support if user wishes that (e.g. git stashes do not allow to create a patch from only a subset of modifications, it will always stash all modified files).
On the other hand when unshelving, the menu should allow both shelve-sets and stashed changes.
Comment 1 Ondrej Vrabec 2014-12-19 14:23:01 UTC
Created attachment 151209 [details]
IDE log
Comment 2 Ondrej Vrabec 2014-12-19 14:23:25 UTC
*** Bug 246076 has been marked as a duplicate of this bug. ***
Comment 3 Ondrej Vrabec 2015-01-11 15:43:20 UTC
fix: http://hg.netbeans.org/core-main/rev/716d9126c139
Comment 4 Ondrej Vrabec 2015-01-11 15:43:25 UTC
fix: http://hg.netbeans.org/core-main/rev/21cb2acdc15d
Comment 5 Ondrej Vrabec 2015-01-11 15:44:48 UTC
last fix:  http://hg.netbeans.org/core-main/rev/c0caf2d0cead - shelve changes is primarily implemented with git stashes for git vcs
Comment 6 Quality Engineering 2015-01-13 04:17:51 UTC
Integrated into 'main-silver', will be available in build *201501130001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/716d9126c139
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: #249458 - Integrate git stashes with shelve changes
Adding shelve menu to the git popup menu.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo