Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 248986 - After update and restart crash - after that can not start/restart.
After update and restart crash - after that can not start/restart.
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: Autoupdate
8.1
PC All
: P1 with 2 votes (vote)
: TBD
Assigned To: Libor Fischmeistr
au-issues
:
: 248291 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-28 15:43 UTC by peterd1212
Modified: 2015-07-07 12:44 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Error log after restart (after update) (97.77 KB, application/octet-stream)
2014-11-28 15:43 UTC, peterd1212
Details
Log folder (23.65 KB, application/x-gzip)
2014-12-01 12:59 UTC, jhernos
Details
modules before update (53.71 KB, text/plain)
2014-12-05 16:31 UTC, knorke
Details
log files in C:\Users\master\AppData\Roaming\NetBeans\8.0\var\log (137.21 KB, application/octet-stream)
2014-12-11 13:03 UTC, marckoby
Details
Update Failure log (374.31 KB, application/octet-stream)
2015-02-11 15:38 UTC, Megachip
Details

Note You need to log in before you can comment on or make changes to this bug.
Description peterd1212 2014-11-28 15:43:26 UTC
Created attachment 150770 [details]
Error log after restart (after update)

After update (26.10.2014 - WinXP, 28.10.2014 - Ubuntu 32b) and restart I get error (see attachment). After that Netbeans are not able to start or restart.

After clean installation (both OS, adding the same plugins and update) I get the same error.

I am using python plugin.
https://blogs.oracle.com/geertjan/entry/python_in_netbeans_ide_8

From plugin repository: http://deadlock.netbeans.org/hudson/job/nbms-and-javadoc/lastStableBuild/artifact/nbbuild/nbms/updates.xml.gz



Thanks
pd
Comment 1 jhernos 2014-12-01 12:27:26 UTC
Exactly same problem with NetBeans 8.0.2 & Python plugins on CentOS 6.6 (64bit).
Comment 2 Libor Fischmeistr 2014-12-01 12:32:53 UTC
Please provide the IDE logs - the whole packed folder would be great.

http://wiki.netbeans.org/FaqLogMessagesFile

Thanks
Comment 3 jhernos 2014-12-01 12:58:20 UTC
Hmm... This thing has probably nothing to do with the Python plugins - I removed ~/.netbeans directory and started NetBeans again. After that, I added the plugin repository http://deadlock.netbeans.org/hudson/job/nbms-and-javadoc/lastStableBuild/artifact/nbbuild/nbms/updates.xml.gz BUT without installing any python plugins. Then I checked for updates and one was found (IDE update plugin), after letting NetBeans to install it, it breaks down.

Attached you find the zipped folder ~/.netbeans/8.0.2/var/log.
Comment 4 jhernos 2014-12-01 12:59:28 UTC
Created attachment 150810 [details]
Log folder
Comment 5 jhernos 2014-12-02 05:43:20 UTC
This bug was marked accidentally as resolved which it isn't...
Comment 6 Antonin Nebuzelsky 2014-12-03 11:12:25 UTC
It is unfortunate that the Python plugin is not available on an Update Center specific for the release, e.g. Plugin Portal UC. And the users are requested to register Update Center of trunk daily builds.

Geertjan, Jirka, can you make sure Python (and maybe other popular downloads) are published on PP UC for 8.0.x?

In general, installing anything from the trunk daily update center is not guaranteed to work with any released version of NetBeans. There may be incompatibilities in trunk, broken functionality, or bugs which can make the modules of trunk completely unusable.
Comment 7 Jiri Kovalsky 2014-12-03 13:55:23 UTC
I am trying to find a new owner for Python who would publish the plugin in the Plugin Portal. Let's see if there is any kind volunteer. :)
Comment 8 Libor Fischmeistr 2014-12-04 07:21:58 UTC
*** Bug 248291 has been marked as a duplicate of this bug. ***
Comment 9 knorke 2014-12-05 16:21:44 UTC
I have the same problem with NB8.0.2 (GNU/Linux, Oracle-JDK 1.7.0-71)

Steps to reproduce:

- completely remove "~/.netbeans" and "~/.cache/netbeans" folder
- starting netbeans with "netbeans-8.0 --list --modules 2>&1 |tee log", accepting EULA etc.

Netbeans works, Infos:

Product Version: NetBeans IDE 8.0 (Build 20140424-unknown-revn)
Java: 1.7.0_71; Java HotSpot(TM) 64-Bit Server VM 24.71-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_71-b14
System: Linux version 3.16.5-gentoo running on amd64; ANSI_X3.4-1968; en_US (nb)

- "Check for Updates" yields exact one update: RCP Platform, Auto Update Service (1.45.1 -> 1.47.2), update succeeds (no file or project opened)
- Restart Netbeans
- Agreed to send statistics ;)
- "Check for Updates" yields 49 updates. I have a log file (pasted from the Update Screen) I can provide you with. Updated succeeded.
- Restart Netbeans (with --list --modules into another log file)
- NB Version is now: Product Version: NetBeans IDE 8.0.2 (Build 201411181905)
- "Check for Updates" yields no updates.
- Adding Python Plugin in the Plugins->Settings tab by "Add"ing the URL

http://deadlock.netbeans.org/hudson/job/nbms-and-javadoc/lastStableBuild/artifact/nbbuild/nbms/updates.xml.gz

- Now, with Python-Plugin added, I have another "Auto Update Service" update available! (v1.47.2 -> 1.49!). As soon as I remove the Python Plugin update source this available update will be also removed! I leave this update marked (as in "will be updated") for now.
- Search for "Python" in "Available Plugins". Yields v0.107. I'm marking this and only this Plugin for installation. Now NB displays the info:

The following plugins will be installed:
Embedded Browser UI - JavaFX WebView [1.13.0.1.1] 
Python [0.107]

The following plugins will also be installed because one or more of the plugins you are about to install depend on them:

Editor Document API [1.3.0.1] 
Filesystems NetBeans Client [9.1] 
Jython Distribution [2.12] 
Progress API - Swing [1.42]

Installation succeeded.

- Restart NB
- FAIL! Cannot start with error posted below: "could not install modules" (and a long list)!

- Now lets try this again, starting all over but BEFORE installing the Python plugin I updated the Auto Update Service (1.47.2 -> 1.49).

Information from NB during this process:

Struts
Update Centers [1.36.2 -> 1.38] Subversion     
Auto Update Services [1.47.2 -> 1.49] 

and dependencies

Ant     
Base Utilities API [8.39.1 -> 9.3]     
File System API [8.12.1 -> 9.3]     
Lookup API [8.25.1 -> 8.30]     
Module System API [7.43.1 -> 7.46] 

Bugzilla     
OSGi Specification [1.18.1 -> 1.19] 

Hudson UI     
Common Annotations [1.24.1 -> 1.25] 

IDE-Plattform     
NetBeans Equinox Integration [1.36.1 -> 1.38]     
NetBeans OSGi Integration [1.27.1 -> 1.29] 

Notifications     
Bootstrap [2.69.3 -> 2.72]     
Startup [1.55.2 -> 1.58] 

OW2 ASM [5.1] 
Progress API - Swing [1.42] 

RCP-Plattform     
Apache's Felix OSGi Implementation [2.12.1 -> 2.13] 

REST HTML5 Client     
Progress API [1.38.1 -> 1.43] 

Software als Dienst     
Progress UI [1.29.2 -> 1.31] 

Struts     
Dialogs API [7.38.1 -> 7.40]     
Nodes API [7.39.1 -> 7.41]     
UI Utilities API [7.62.1 -> 7.64]     
Window System API [6.71.1 -> 6.73] 

Utilities API [9.3] 

Update succeeded.

- Restart FAILED! Same error message. :(
Comment 10 knorke 2014-12-05 16:31:23 UTC
Created attachment 150922 [details]
modules before update

first start, fresh gentoo install.
Comment 11 marckoby 2014-12-11 12:53:12 UTC
This happened to me because I tried adding wiki.netbeans.org/ScanOnDemand and (forced to) follow their suggestion to add "Latest Development Plugins" in the update center. Now Netbeans 8.0.2 won't start at all.
Comment 12 marckoby 2014-12-11 13:03:41 UTC
Created attachment 151043 [details]
log files in C:\Users\master\AppData\Roaming\NetBeans\8.0\var\log

Nothing to do with Python, in my case.
Tried to install
http://wiki.netbeans.org/ScanOnDemand

which had me add:
 http://deadlock.netbeans.org/hudson/job/nbms-and-javadoc/lastStableBuild/artifact/nbbuild/nbms/updates.xml.gz 


Now, getting this error:
https://netbeans.org/bugzilla/show_bug.cgi?id=248291#c5

At the end, either "Exit" or "Disable Modules and Continue" which also exits, so Netbeans 8.0.2 x86 Win8.1 does not start at all.
Comment 13 marckoby 2014-12-11 13:05:31 UTC
(In reply to marckoby from comment #12)
> Created attachment 151043 [details]
> log files in C:\Users\master\AppData\Roaming\NetBeans\8.0\var\log
> 
> Nothing to do with Python, in my case.
> Tried to install
> http://wiki.netbeans.org/ScanOnDemand
> 
> which had me add:
>  http://deadlock.netbeans.org/hudson/job/nbms-and-javadoc/lastStableBuild/
> artifact/nbbuild/nbms/updates.xml.gz 
> 
> 
> Now, getting this error:
> https://netbeans.org/bugzilla/show_bug.cgi?id=248291#c5
> 
> At the end, either "Exit" or "Disable Modules and Continue" which also
> exits, so Netbeans 8.0.2 x86 Win8.1 does not start at all.

Correction, 64-bit platform. Windows 8.1 x64 
 BUILD 9600 or smth
Comment 14 marckoby 2014-12-11 14:54:14 UTC
A reinstallation to a newer version may be inevitable, 
since for example 

C:\ProgramFiles\NetBeans\platform\core\org-openide-filesystems-compat8.jar

was entirely missing from my fatally broken Netbeans 8.0.2

Yet that alone seemed to be implicated in the first and most repeated startup error:
Warning - could not install some modules: Task List API - The module named org.openide.filesystems.compat8 was needed and not found.




Eventually I had to install-overwrite the nightly build. See  http://stackoverflow.com/a/27425546/1069375
Comment 15 tomau 2014-12-12 09:40:28 UTC
Check Geertjan's blog post:
https://blogs.oracle.com/geertjan/entry/python_in_netbeans_ide_81

Tried this and works with Netbeans 8.0.2 in CentOs 6.6.
Comment 16 Jiri Kovalsky 2014-12-12 11:13:25 UTC
Please reinstall the IDE and next time try to avoid installing development quality plugins into stable quality product. BTW, Geertjan published the Python plugin for 8.0.2 on the Plugin Portal [1] recently. This will hopefully work fine. Or even better, you can join Lou Dasaro (Cc:ed here) in his effort to resurrect the Python plugin [2].

[1] http://plugins.netbeans.org/plugin/56795
[2] https://docs.google.com/spreadsheets/d/1gIv55HhSkOo-Ozju2uuRVNxXp32Umz5HPNlj5N9ecdk
Comment 17 scamo 2014-12-28 09:16:36 UTC
This also happened to me. 

First Windows crashed with a BSoD during the upgrade and then at the restart of Windows and Netbeans I got the exact same errors as above. I have the PHP version.

Netbeans 8.0.1
Windows 7
Dark Themes Plug-in

I've reinstalled 8.0.2 and also the plug-in and reimported user settings. All is working again. Phew.....

I also noticed that Netbeans was complaining about me having a 32 bit JRE installed. So I went and corrected it to the newest 64 bit JRE. I am not sure that had anything to do with the crash, but maybe that info can be helpful.
Comment 18 scamo 2014-12-28 09:19:38 UTC
Hmm... can't edit my post here. 

In addition to the above just to be sure it makes sense. The complaining about the 32 bit JRE happened during the installation process. So I stopped the installation and then changed the JRE and then installed NB8.0.2.
Comment 19 Libor Fischmeistr 2015-01-05 07:38:17 UTC
(In reply to Jiri Kovalsky from comment #16)
> Please reinstall the IDE and next time try to avoid installing development
> quality plugins into stable quality product. BTW, Geertjan published the
> Python plugin for 8.0.2 on the Plugin Portal [1] recently. This will
> hopefully work fine. Or even better, you can join Lou Dasaro (Cc:ed here) in
> his effort to resurrect the Python plugin [2].
> 
> [1] http://plugins.netbeans.org/plugin/56795
> [2]
> https://docs.google.com/spreadsheets/d/1gIv55HhSkOo-
> Ozju2uuRVNxXp32Umz5HPNlj5N9ecdk

This is the reason why I'm closing this issue as wontfix.

Simply you cannot mix development UC and stable release.
Comment 20 Megachip 2015-02-11 15:38:20 UTC
Created attachment 151953 [details]
Update Failure log
Comment 21 marckoby 2015-06-22 12:45:20 UTC
In my case this had NOTHING to do with:
 1) Python pluggins nor python anything, unlike in http://stackoverflow.com/questions/27190831/error-in-netbeans-8-0-startup/27681320#27681320
 2) "stable" Netbeans, as I have been using Dev builds since Dec2014, now NetBeans build 201506220001, where this was STILL a fatal problem;
 3) No extra plug catalogs had been added, nor pluggins manually installed, other than those already bundled with the installer or chosen from the existing list of those available.


Startup errors like this:


Warning - could not install some modules: CSS Preprocessors - The module named org.netbeans.modules.css.editor/1 was needed and not found. HTML Editor - The module named org.netbeans.modules.css.editor/1 was needed and not found. JavaScript2 Editor - The module named org.netbeans.modules.css.editor/1 was needed and not found. JavaScript2 jQuery - The module named org.netbeans.modules.css.editor/1 was needed and not found. CSS Visual Editor - The module named org.netbeans.modules.css.editor/1 was needed and not found. HTML5 Kit - The module named org.netbeans.modules.javascript.cdnjs/0-1 was needed and not found. 59 further modules could not be installed due to the above problems.


Sometimes I'd hit "Continue" instead of "Exit", then this would briefly follow, then entirely disappear with the netbeans.exe process:


org.osgi.framework.BundleException: R3 imports cannot contain directives.
	at org.apache.felix.framework.util.manifestparser.ManifestParser.normalizeImportClauses(ManifestParser.java:351)
	at org.apache.felix.framework.util.manifestparser.ManifestParser.<init>(ManifestParser.java:163)
	at org.apache.felix.framework.BundleRevisionImpl.<init>(BundleRevisionImpl.java:118)
	at org.apache.felix.framework.BundleImpl.createRevision(BundleImpl.java:1199)
	at org.apache.felix.framework.BundleImpl.<init>(BundleImpl.java:96)
	at org.apache.felix.framework.Felix.installBundle(Felix.java:2899)
	at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:165)
	at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:138)
	at org.netbeans.core.netigso.Netigso.fakeOneModule(Netigso.java:493)
Caused: java.io.IOException
	at org.netbeans.core.netigso.Netigso.fakeOneModule(Netigso.java:519)
[catch] at org.netbeans.core.netigso.Netigso.prepare(Netigso.java:176)
	at org.netbeans.NetigsoHandle.turnOn(NetigsoHandle.java:138)
	at org.netbeans.ModuleManager.enable(ModuleManager.java:1339)
	at org.netbeans.ModuleManager.enable(ModuleManager.java:1156)
	at org.netbeans.core.startup.ModuleList.installNew(ModuleList.java:340)
	at org.netbeans.core.startup.ModuleList.trigger(ModuleList.java:276)
	at org.netbeans.core.startup.ModuleSystem.restore(ModuleSystem.java:301)
	at org.netbeans.core.startup.Main.getModuleSystem(Main.java:181)
	at org.netbeans.core.startup.Main.getModuleSystem(Main.java:150)
	at org.netbeans.core.startup.Main.start(Main.java:307)
	at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:123)
	at java.lang.Thread.run(Thread.java:745)


Eventually I searched, using Everthing Search which quickly checks ntfs journals, for things hinted from the errors, like

*modules*css*editor*

and sorted the results by most recent modified timestamp....

...which lead me to a workaround (aside from all the leaps of faith thus far):


For anyone else who lands onto the unfixed bug following an innocent auto-update, having tried countless advanced experiments hacking into the Netbeans installation and %appdata% xml files etc., this put things back on track, it seems.




The last action I did, before a launch of Netbeans started working again(actually showing the GUI etc. and not silently exiting the process within a minute), was to delete this new, zero-sized file:

 
org-netbeans-modules-css-editor.xml_hidden

from:



C:\Users\master\AppData\Roaming\NetBeans\dev\config\Modules\



Before that, have painstakingly studied what's going in from messages.log and widely opened up universal read and write and ownership permissions on all directories remotely touched by NB:

  Current Directory       = C:\ProgramFiles\NetBeans
  User Directory          = C:\Users\master\AppData\Roaming\NetBeans\dev
  Cache Directory         = C:\Users\master\AppData\Local\NetBeans\Cache\dev
  Installation            = C:\ProgramFiles\NetBeans\nb



cd into each of those folder under an admin shell;

 takeown /R /D Y /F .

 ICACLS  *   /grant "Everyone":F /T



 psexec -i -s cmd.exe  ## local System account has higher privileges than Administrator.
Comment 22 Libor Fischmeistr 2015-07-07 12:44:09 UTC
(In reply to marckoby from comment #21)
> In my case this had NOTHING to do with:
>  1) Python pluggins nor python anything, unlike in
> http://stackoverflow.com/questions/27190831/error-in-netbeans-8-0-startup/
> 27681320#27681320
>  2) "stable" Netbeans, as I have been using Dev builds since Dec2014, now
> NetBeans build 201506220001, where this was STILL a fatal problem;
>  3) No extra plug catalogs had been added, nor pluggins manually installed,
> other than those already bundled with the installer or chosen from the
> existing list of those available.
> 
> ...

In that case, I think you should report a new issue. Attach the IDE log please.

http://wiki.netbeans.org/FaqLogMessagesFile


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo