Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 248575 - IllegalStateException: Module org.netbeans.modules.java.source.base is already enabled
IllegalStateException: Module org.netbeans.modules.java.source.base is alread...
Status: RESOLVED DUPLICATE of bug 247884
Product: platform
Classification: Unclassified
Component: Autoupdate
8.1
All All
: P2 (vote)
: TBD
Assigned To: Libor Fischmeistr
au-issues
EXCEPTIONS_REPORT
:
: 248561 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-11 14:13 UTC by zdenek.rod
Modified: 2015-03-17 08:33 UTC (History)
10 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.55 KB, text/plain)
2014-11-11 14:13 UTC, zdenek.rod
Details
stacktrace (3.60 KB, text/plain)
2015-02-02 09:28 UTC, ehsavoie
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zdenek.rod 2014-11-11 14:13:13 UTC
Build: NetBeans IDE Dev (Build 201411110002)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.25-b02, Java(TM) SE Runtime Environment, 1.8.0_25-b18
OS: Windows 7

User Comments:
GUEST: unknown error

GUEST: importing plugins from previous version

GUEST: exception

zdenek.rod: I am installing find bugs plugin.

zdenek.rod: I dont do anything importan. I only opened wsdl file from project files.

GUEST: auto import




Stacktrace: 
java.lang.IllegalStateException: Module org.netbeans.modules.java.source.base is already enabled
   at org.netbeans.ModuleManager.attachModuleFragment(ModuleManager.java:1019)
   at org.netbeans.ModuleManager.maybeAddToEnableList(ModuleManager.java:1585)
   at org.netbeans.ModuleManager.maybeAddToEnableList(ModuleManager.java:1595)
   at org.netbeans.ModuleManager.simulateEnable(ModuleManager.java:1534)
   at org.netbeans.ModuleManager.simulateEnable(ModuleManager.java:1508)
   at org.netbeans.core.startup.ModuleList.installNew(ModuleList.java:314)
Comment 1 zdenek.rod 2014-11-11 14:13:14 UTC
Created attachment 150432 [details]
stacktrace
Comment 2 Jaroslav Tulach 2014-11-11 15:01:07 UTC
Another fragment issue.
Comment 3 Svata Dedic 2014-11-13 12:30:22 UTC
This concrete issues is interim and will disappear once proper spec versions propagate to the NBMs on the update centre.

In general, the issue happens, when a functioning module is updated from UC to a newer module (higher spec), which brings in a module fragment of an enabled module. I am almost sure this is not a proper use-case as long as we only use module fragments for backward compatibility patching: a module does not depend on it, but rather implies a need for module fragment if it is too old. In this scenario, we actually upgrade the module, so the new version cannot be that old.

However in general, it's another issue of AutoUpdate to handle. I can imagine a module that for whatever reason start to depend on a module fragment in its new (updated) version. In that case, AutoUpdate should suggest to restart the IDE instead of just leave the module system to enable all updated mods.
Comment 4 Svata Dedic 2014-11-13 12:50:31 UTC
*** Bug 248561 has been marked as a duplicate of this bug. ***
Comment 5 Exceptions Reporter 2015-02-01 12:10:05 UTC
This bug already has 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=212932
Comment 6 ehsavoie 2015-02-02 09:28:05 UTC
Created attachment 151776 [details]
stacktrace

Importing plugins from 8.0.2 installation
Comment 7 Libor Fischmeistr 2015-03-17 08:33:15 UTC
I thing it's a duplicate of the issue 247884.

If someone can reproduce this, please increase priority and provide us the exact steps to reproduce and both IDE and updater logs - http://wiki.netbeans.org/FaqLogMessagesFile

*** This bug has been marked as a duplicate of bug 247884 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo