Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 248182 - IDE cannot start new tomcat installation
IDE cannot start new tomcat installation
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: Tomcat
8.0
PC Windows XP
: P2 with 1 vote (vote)
: 8.1
Assigned To: Petr Hejl
issues@serverplugins
:
: 241045 248048 248120 249308 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-25 03:25 UTC by bht
Modified: 2019-01-04 18:13 UTC (History)
3 users (show)

See Also:
Issue Type: TASK
:


Attachments
IDE log (131.63 KB, text/plain)
2014-10-25 03:25 UTC, bht
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bht 2014-10-25 03:25:44 UTC
Created attachment 150111 [details]
IDE log

From multiple different zip downloads. I chose only zip, windows 32 bit.
http://mirror.sdunix.com/apache/tomcat/tomcat-7/v7.0.56/bin/apache-tomcat-7.0.56-windows-x86.zip

Extract
Register with IDE
username tomcat
password tomcat

start it from the IDE.

'127.0.0.1' is not recognized as an internal or external command,
operable program or batch file.
Comment 2 Petr Hejl 2014-11-14 09:22:01 UTC
*** Bug 248120 has been marked as a duplicate of this bug. ***
Comment 3 Petr Hejl 2014-11-14 09:24:49 UTC
*** Bug 248048 has been marked as a duplicate of this bug. ***
Comment 4 Petr Hejl 2014-11-14 09:25:33 UTC
Seems to be a problem with the bat files on windows. I'll try to workaround it.
Comment 6 Petr Hejl 2014-11-26 14:44:53 UTC
Should be fixed in jet-main 503bd72244c2. Please verify in daily build. Keeping it open to do some state caching.
Comment 7 Quality Engineering 2014-11-27 04:23:43 UTC
Integrated into 'main-silver', will be available in build *201411270001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/503bd72244c2
User: Petr Hejl <phejl@netbeans.org>
Log: #248182 - IDE cannot start new tomcat installation
Comment 8 Petr Hejl 2014-12-01 10:32:31 UTC
*** Bug 241045 has been marked as a duplicate of this bug. ***
Comment 9 Petr Hejl 2015-01-30 12:10:13 UTC
Fixed, including caching - web-main 2a485c2ec8d3.
Comment 10 Quality Engineering 2015-01-31 07:56:44 UTC
Integrated into 'main-silver', will be available in build *201501310002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/2a485c2ec8d3
User: Petr Hejl <phejl@netbeans.org>
Log: #248182 - IDE cannot start new tomcat installation
Comment 11 Petr Hejl 2015-03-03 11:26:11 UTC
*** Bug 249308 has been marked as a duplicate of this bug. ***
Comment 12 arksoft 2016-05-13 16:25:08 UTC
Why not just give the answer instead of putting everyone into the "Duplicate Infinite Loop"?

in bin/catalina.bat, change from
set "JAVA_OPTS=%JAVA_OPTS% %LOGGING_CONFIG%"
set "JAVA_OPTS=%JAVA_OPTS% %LOGGING_MANAGER%"

to

set JAVA_OPTS=%JAVA_OPTS% %LOGGING_CONFIG%
set JAVA_OPTS=%JAVA_OPTS% %LOGGING_MANAGER%


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo