Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 24776 - Weak File Ordering Support
Weak File Ordering Support
Status: RESOLVED DUPLICATE of bug 103187
Product: platform
Classification: Unclassified
Component: Filesystems
3.x
All All
: P4 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-14 14:35 UTC by _ lkramolis
Modified: 2008-12-22 09:50 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Templates (RMI module disabled). (40.37 KB, image/jpeg)
2002-06-14 14:36 UTC, _ lkramolis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ lkramolis 2002-06-14 14:35:08 UTC
Because of your reorganization of templates'
order, it is simple to break such order.

E.g. XML module, you made one rule that RMI
templates are before XML's but if you disable RMI
module then folder with XML templates is directly
after Folder template (see attachment).
Comment 1 _ lkramolis 2002-06-14 14:36:21 UTC
Created attachment 6261 [details]
Templates (RMI module disabled).
Comment 2 Marek Grummich 2002-07-22 11:43:37 UTC
Set target milestone to TBD
Comment 3 Marek Grummich 2002-07-22 11:47:01 UTC
Set target milestone to TBD
Comment 4 jrojcek 2002-12-02 15:39:03 UTC
I think this is a general problem of ordering an items provided by
modules. Suppose you have three unrelated modules in a distribution of
NetBeans IDE each supplying one item - A, B, C. You want to order them
lets say alphabetically.

To get such order with current ordering system, you have to specify
that B goes after A, and C goes after B. But this is not enough, you
have to specify also that C goes after A in case B module (module
providing the B item) is uninstalled. So following ordering is defined:
  B is after A
  C is after A
  C is after B

Now, suppose third party module, which is installed by the user in
addition to IDE modules, supplies an X item, and wants to achieve
ordering A, B, X, C. So, the module should define this:
  X is after A
  X is after B
  X is before C
, to count also a case if B module is uninstalled.

Since now, everything looks good. But what if a new distribution of
the IDE changes ordering of A, B, C items to B, C, A? It can be quite
a lot of work to change it for many modules, but it should work well
like this:
  C is after B
  A is after B
  A is after C

And now, suppose the user of the new IDE downloads module providing
the X item. There is only one version of the module, with an ordering
fitting into old IDE. The result of the module installation would be
that all items A, B, C, X will mess up, as it will not possible to
satisfy all ordering rules. This can cause a usability problem, when
an order of menu items/templates suddenly becomes a disorder.

There are two points in this comment:
* defining an ordering rules and considering uninstalling of modules
may increase probability that if something changes everything would
stop work.
* there should be a method, which assures that third party modules
would not break ordering of items provided by the IDE.

Well, maybe above situation is very rare, but it is worth to consider,
IMO.

Anyway, this issue should be reassigned to development/implementation
team.
Comment 5 Marian Mirilovic 2003-02-20 12:52:20 UTC
Jirka, 
please look at this, I am not sure we can order explicitly after each
module addition templates again...
Comment 6 Jiri Rechtacek 2003-02-27 08:46:55 UTC
It's a general problem with ordering in layer declared object. It must
be solved generally for next release.
Comment 7 Jiri Rechtacek 2003-03-24 14:15:46 UTC
Each module is responsible to define all its dependencies. i.e. all
templates prior to declared template. It's maintenance intensive but
as designed (I close as wontfix).
Libor, optionally start a discussion on openide-dev if you want.
Comment 8 Jiri Rechtacek 2003-03-24 14:18:12 UTC
Similar issue 32147...
Comment 9 _ pkuzel 2003-03-24 14:59:03 UTC
Current system requires me to have prior knowledge about ALL modules
that my template should follow. WONTFIX is not acceptable from module
maintenace point of view.
Comment 10 Jiri Rechtacek 2003-03-28 13:48:01 UTC
Ok, I close as duplicate of issue 32147, both issue talks about same
problem, specify position in order. It's a general task for module's
layer, not wizard subcomponent.

*** This issue has been marked as a duplicate of 32147 ***
Comment 11 _ pkuzel 2003-03-31 09:36:54 UTC
I do not agree with you. This issue i.e. lack of robust ordering
mechanicm is cause of issue 32147. I'll reopen it and mark as LATER
because it seems that you are not interested in it just now.
Comment 12 _ pkuzel 2003-03-31 09:40:08 UTC
It's rather fs enhancement than wizards defect.
Comment 13 Jesse Glick 2007-05-15 21:04:31 UTC

*** This issue has been marked as a duplicate of 103187 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo