Bug 24701 - Filesystem order is not preserved
Filesystem order is not preserved
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: Tomcat
3.x
All All
: P1 (vote)
: 3.x
Assigned To: Damian Frach
issues@platform
:
: 24660 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-12 15:34 UTC by Milan Kubec
Modified: 2002-10-17 12:14 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
filesystems before restart (3.95 KB, image/png)
2002-06-13 09:33 UTC, Milan Kubec
Details
filesystems after restart (3.89 KB, image/png)
2002-06-13 09:34 UTC, Milan Kubec
Details
dump to console with org.netbeans.core.AutomountSupport=-1 (45.31 KB, text/plain)
2002-06-13 10:37 UTC, Milan Kubec
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Kubec 2002-06-12 15:34:00 UTC
[dev-200206120100] Order of mounted filesystems is
not preserved after restart of IDE. Filesystems
are alphabeticaly sorted after restart.
Comment 1 _ ttran 2002-06-12 15:41:34 UTC
automount again?

-> dstrupl
Comment 2 David Strupl 2002-06-12 17:08:41 UTC
I have tried on JDK1.4.0 FCS and it works as expected.
Milan: JDK? Anything you had done before it started to occur (old
userdir)? Any steps to reproduce?
Comment 3 Jesse Glick 2002-06-12 18:39:50 UTC
This has happened to me as well with 3.4b1. Normally the order is
preserved after a restart. But at least once, the filesystems I had
mounted got rearranged. No idea how to reproduce. 1.4.0_01.
Comment 4 Milan Kubec 2002-06-13 09:31:34 UTC
I can easily reproduce it:

1) start IDE with clean userdir
2) mount number of folders (alphabeticaly unsorted)
3) restart IDE
4) filesystems are sorted

I will attach scrshots. I'm running dev-200206130100, JDK 1.4.0_01, RH
7.2.
Comment 5 Milan Kubec 2002-06-13 09:33:28 UTC
Created attachment 6242 [details]
filesystems before restart
Comment 6 Milan Kubec 2002-06-13 09:34:42 UTC
Created attachment 6243 [details]
filesystems after restart
Comment 7 Milan Kubec 2002-06-13 10:37:00 UTC
Created attachment 6246 [details]
dump to console with org.netbeans.core.AutomountSupport=-1
Comment 8 David Strupl 2002-06-13 13:38:56 UTC
I am unable to reproduce with my own build. However it does occur when
I use the official build. Very strange.
Comment 9 David Strupl 2002-06-14 08:44:47 UTC
Status update: now I know the difference between my build and the
official build. I was not building tomcatint module correctly. They
have a provision in the build script allowing to finish the build even
if you don't have all extra binaries available. So I was effectively
building without tomcat40. When I build with tomcat40 the issue is
100% reproducible. The problematic code is called from this module
installed method. Without this module the problem does not occur.
Comment 10 David Strupl 2002-06-14 09:55:16 UTC
Damian, could you please remove all adding and removing of the
temporary filesystems to/from the repository. I have succeeded in
getteing rid of the problem by commenting all rep.addFileSystem and
rep.removeFileSystem in file
org.netbeans.modules.tomcat.tomcat40.Tomcat40Installation.

It should be also faster if you don't play with repository in
module.installed().

If you would have any problems please contact me. Thanks.
Comment 11 Damian Frach 2002-06-14 12:32:42 UTC
Reason for adding and removing temp FSs to repository is 
gone.

So, it was removed.

Comment 12 Damian Frach 2002-06-14 12:33:52 UTC
*** Issue 24660 has been marked as a duplicate of this issue. ***
Comment 13 Marian Mirilovic 2002-06-14 12:38:56 UTC
This issue is pointed as Q-build stopper (20020612) -> please commit
the fix to QBE branch.
Comment 14 David Strupl 2002-06-14 14:44:38 UTC
Commited to the Q-build branch.
Comment 15 Milan Kubec 2002-10-17 12:14:37 UTC
Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo