Bug 24698 - Output Window usually does not hyperlink requested lines
Output Window usually does not hyperlink requested lines
Status: CLOSED FIXED
Product: cnd
Classification: Unclassified
Component: Terminalemulator
3.x
PC Linux
: P2 (vote)
: 6.x
Assigned To: akemr
ivan
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-12 15:03 UTC by Milan Kubec
Modified: 2008-12-23 08:20 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
ant output from cmd line (1.82 KB, text/plain)
2002-06-13 09:15 UTC, Milan Kubec
Details
Output window from IDE scrshot (22.55 KB, image/png)
2002-06-13 09:17 UTC, Milan Kubec
Details
Explorer view over filesystem scrshot (10.75 KB, image/png)
2002-06-13 09:21 UTC, Milan Kubec
Details
Sample Java class (internal execution) (837 bytes, text/plain)
2002-06-17 02:51 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Kubec 2002-06-12 15:03:04 UTC
If compilation in ant script fails links to
sources (in Output window) are created only if
sources are explicitly mounted with correct
package. It means that if I just mount one module
folder (with script and src/ folder) and execute
build script compilation errors are not linked.
It's regression therefore P2.
Comment 1 Milan Kubec 2002-06-12 16:41:38 UTC
I've observed very strange behavor of filesystems:

1) I've mounted folder two levels above src/ folder so I was able to
execute ant scripts for multiple modules. 
2) I executed one build script, it failed and links were not created. 
3) Then I mounted folder src/ with proper sources and excuted that
script again, but links were not created either. 
4) So I restarted IDE and executed that script again - links were
created. 
5) Then I unmount src/ folder and executed that script again and links
were created. 
6) I restarted IDE again, executed script and links were not created. 

Also I was able to open files linked from Output window as
org.netbeans... although I didn't have src/ folder mounted.

So it looks that filesystems are cached somehow.
Comment 2 Jesse Glick 2002-06-12 17:05:05 UTC
I am unaware of any such problem. If the compiler produces good
output, with complete file names, it should always be linked (if the
file is present in some filesystem; package irrelevant). If partial
file names are output, mount points matter. jikes +E I know does a
good job of producing link-friendly output.

Please attach (1) the literal output of the script from the command
line, (2) processed output as shown in the Output Window, (3) list of
filesystem mounts.
Comment 3 bwl 2002-06-12 23:43:42 UTC
*** Issue 24474 has been marked as a duplicate of this issue. ***
Comment 4 Milan Kubec 2002-06-13 09:15:49 UTC
Created attachment 6239 [details]
ant output from cmd line
Comment 5 Milan Kubec 2002-06-13 09:17:45 UTC
Created attachment 6240 [details]
Output window from IDE scrshot
Comment 6 Milan Kubec 2002-06-13 09:21:38 UTC
Created attachment 6241 [details]
Explorer view over filesystem scrshot
Comment 7 Milan Kubec 2002-06-13 09:24:43 UTC
All requested attached. I'm using dev-200206130100, jdk 1.4.0_01, RH 7.2.
Comment 8 David Konecny 2002-06-13 14:11:54 UTC
I'm going to investigate this issue. (Brett, I added you on the CC to 
be notified when it is resolved)
Comment 9 David Konecny 2002-06-13 14:34:06 UTC
I cannot reproduce it on my Win2000 with Build 200206130951 neither on 
JDK 1.3.1_02-b02 nor on JDK 1.4.0-b92. I asked Milan to test it on his 
machine on 1.3.x JDK and also to try to reproduce it on some Win2000 
machine.
Comment 10 Jesse Glick 2002-06-13 16:05:20 UTC
Note precise algorithm for finding a hyperlink should be:

1. Check all filesystems and select those which could contain the file
mentioned in the output.

2. If any of them are marked Use in Compiler, use those in preference
to any that are not.

3. To break ties, select the filesystem with the longest root prefix
(and thus shortest relative path to the file).

I guess you have nothing else mounted, so
/space/sources/netbeans/trunk/ ought to be used.

Are any of the path components actually symlinks on your machine?
Comment 11 Milan Kubec 2002-06-13 16:21:01 UTC
None of folders is symlink. 

I reproduced it on Win2000 too.
Comment 12 nczempin 2002-06-16 22:32:03 UTC
I have a similar problem, if not the same:

(Windows 2k 
200206070835)

1. cvs-mount the contrib module,.
2. change the 
build.xml file in contrib/audit to produce a syntax error (I changed the 
first "property" to "propety")
3. right-click on build.xml -> 
execute
4. you get the error message, but no link.
5. If you use 
contrib/audit as mount point, you do get the link
6. if you then unmount 
contrib/audit, the error message does *not* get linked any more.

It 
may be an issue with relative paths within the build.xml: Note that the 
usual place for these files is directly under a module; because of the 
"unusual" nature of contrib, I have to put mine one level deeper.
Comment 13 Jesse Glick 2002-06-17 02:50:26 UTC
This is a problem in output window code. See the attached simple test
case, which has nothing to do with Ant. In [dev jun 14], using MDI,
JDK 1.4.0_01, Linux 2.4.7, when run I get this output (of course):

c.x
a.x
b.x

where c.x is linked and b.x is linked but a.x is not linked! It seems
that any given string will or not be linked successfully in a
mysterious fashion. A particular string will either always be linked
or never linked, regardless of other things that are printed before or
after it.
Comment 14 Jesse Glick 2002-06-17 02:51:33 UTC
Created attachment 6277 [details]
Sample Java class (internal execution)
Comment 15 akemr 2002-06-17 15:49:24 UTC
I fixed in trunk output window bug (reproduced thanks to Jesse
example), so marking as fixed.
I'm not sure, if it was cause of all noticed problems.
Comment 16 Milan Kubec 2002-06-19 12:53:45 UTC
At least ant compilation errors are now linked OK.

Nicolai, could you check your problem?
Comment 17 nczempin 2002-06-19 12:59:40 UTC
Sure, don't worry :-)
But I can usually only work on any NB-stuff on the 
weekend, so it'll have to wait. I'll leave a comment then.
Comment 18 Milan Kubec 2002-10-17 11:36:45 UTC
Verified.
Comment 19 Quality Engineering 2003-07-01 16:44:22 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.
Comment 20 Quality Engineering 2008-12-23 08:20:51 UTC
moving terminal emulator issues to terminalemulator component.
To see the correct version and target milestone of this issue look at Issue
Activity table.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo