Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 246854 - NetBeans crashes when typing via input-method(IME) for input Japanese words.
NetBeans crashes when typing via input-method(IME) for input Japanese words.
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Editor
8.0
PC Windows 7 x64
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-09-03 15:38 UTC by momotaro
Modified: 2014-12-23 02:33 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
JavaVM crash error file (42.26 KB, application/octet-stream)
2014-09-03 15:38 UTC, momotaro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description momotaro 2014-09-03 15:38:06 UTC
Created attachment 149024 [details]
JavaVM crash error file

OS: Windows 7 x64 Japanese Edition.
Java: Java SE 8 Update 20
NetBeans: 8.0

Reproducing procedure.
* Open a java source file in NetBeans java editor.
* Activate Japanese IME(Japanese - Microsoft IME).
* Type some keys, entering and displaying Japanese characters before confirming.
* Hit enter key to confirm unconfirm characters, then crashed.

This crash generates hs_err_pidxxxx.log file. 
Attached some files.

cf. "How To Type Japanese On Your Computer"
http://www.textfugu.com/season-4/social-learning/9-3/
Comment 1 momotaro 2014-09-13 10:56:49 UTC
This crash may be caused by https://bugs.openjdk.java.net/browse/JDK-8055877
Comment 2 momotaro 2014-10-16 15:37:55 UTC
This bug seemed to be fixed by Java SE 8 Update25 fixes the bug 8058858(not public). 

> The VM crashes while using Swing controls when some Japanese or Chinese
> characters are input on Windows platform. The issue is now fixed.

http://www.oracle.com/technetwork/java/javase/8u25-relnotes-2296185.html

So, on Windows 7 x64 and Java SE 8u25, NetBeans 8.0 is not crash when 
inputting Javanese character/Enter key.
Comment 3 deenfirdoush 2014-12-23 02:33:45 UTC
Mine is Windows 8 64 bit. Faced same problem.
I fixed it by 
1) updating jdk1.8_20 to jdk1.8_25
2) changing netbeans_jdkhome="E:\Program Files\Java\jdk1.8.0_25" in the file netbeans.conf under E:\Program Files\NetBeans 8.0.2\etc\netbeans.conf


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo