Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 244325 - IDE popups Windows cmd console window at startup
IDE popups Windows cmd console window at startup
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Launchers&CLI
8.0.1
PC Windows Vista
: P3 with 1 vote (vote)
: 8.1
Assigned To: Libor Fischmeistr
issues@platform
:
: 249812 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-06 10:57 UTC by Maksim Khramov
Modified: 2015-03-11 04:06 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maksim Khramov 2014-05-06 10:57:02 UTC
Product Version: NetBeans IDE Dev (Build 201405030001)
Java: 1.7.0_60-ea; Java HotSpot(TM) 64-Bit Server VM 24.60-b09

Since this build the IDE shows and closes immediately windows cmd.exe window at IDE startup
Comment 1 Jiri Skrivanek 2014-08-13 13:24:06 UTC
I also noticed this behaviour when IDE is installed by the installer and property netbeans_jdkhome is set in netbeans.conf. I was told it is because launcher needs to determine JDK version. Maybe you can read JDK version from java.exe file properties on Windows if it is possible in CPP. Not sure about unixes.
Comment 2 legitalk 2014-11-13 12:57:11 UTC
Product Version: NetBeans IDE 8.0.1 (Build 201408251540)
Updates: NetBeans IDE is updated to version NetBeans 8.0.1 Patch 1.1
Java: 1.8.0_25; Java HotSpot(TM) 64-Bit Server VM 25.25-b02
Runtime: Java(TM) SE Runtime Environment 1.8.0_25-b18
System: Windows 7 version 6.1 running on amd64; Cp1250; sk_SK (nb)

I have the same problem, when NB starts, cmd.exe is shown and then closed. I was investigating it little bit, and it is java.exe, what is launching. When I tried to launch NB with `netbeans.exe --console new`, then it opened cmd.exe, but didnt close.

There was written:

Java HotSpot(TM) 64-Bit Server VM warning: ignoring option PermSize=32m; support
 was removed in 8.0

When I just launch NB from cmd.exe with `netbeans.exe`, there was this:

The launcher has determined that the parent process has a console and will reuse
 it for its own console output.
Closing the console will result in termination of the running program.
Use '--console suppress' to suppress console output.
Use '--console new' to create a separate console window.
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option PermSize=32m; support
 was removed in 8.0
Comment 3 Jiri Skrivanek 2015-01-15 07:46:04 UTC
*** Bug 249812 has been marked as a duplicate of this bug. ***
Comment 4 arnofly 2015-01-15 10:07:12 UTC
JDK 7.71 (32 bits) is still installed on my computer.
JDK 8.25 (32 bits) is newly installed on my computer.

NB 7.3.1 and NB 8.0.2 are installed on my computer.

I made several tests by editing the netbeans.conf file of each NB version.

After a quick swap or not of the JDK version in each NB, in all case the CMD window is still hidden when I launch NB 7.3.1 32bits or 64bits.

With NB 8.0.2, in all case, the CMD window is shown on NB startup. It's true with the 32bits and 64bits exe files of NB.
Comment 5 pdhaene 2015-01-15 12:02:42 UTC
(In reply to arnofly from comment #4)
> JDK 7.71 (32 bits) is still installed on my computer.
> JDK 8.25 (32 bits) is newly installed on my computer.
> 
> NB 7.3.1 and NB 8.0.2 are installed on my computer.
> 
> I made several tests by editing the netbeans.conf file of each NB version.
> 
> After a quick swap or not of the JDK version in each NB, in all case the CMD
> window is still hidden when I launch NB 7.3.1 32bits or 64bits.
> 
> With NB 8.0.2, in all case, the CMD window is shown on NB startup. It's true
> with the 32bits and 64bits exe files of NB.

Hey
I aso have both jdk 7 an 8 installed in x32/64. It does not make any difference.
With NB 8.0 there is no problem and the solution (for now) seems to be to have NB 8.0 and update the ide to 8.0.1 or 8.0.2.
No cmd popup!

cheers.
Comment 6 Topaz9 2015-01-15 13:52:18 UTC
I have a problem with cmd.exe when starting Netbeans. What is the problem? I ran a sfc scannow of System32 and it said it could not fix some of the problems
Comment 7 Libor Fischmeistr 2015-02-26 13:48:20 UTC
*** Bug 250575 has been marked as a duplicate of this bug. ***
Comment 8 Libor Fischmeistr 2015-03-09 13:52:07 UTC
Fixed - http://hg.netbeans.org/core-main/rev/cb53870c8307
Comment 9 Quality Engineering 2015-03-11 04:06:25 UTC
Integrated into 'main-silver', will be available in build *201503110001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/cb53870c8307
User: Libor Fischmeistr <lfischmeistr@netbeans.org>
Log: #244325: IDE popups Windows cmd console window at startup


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo