Bug 243379 - com.sun.tools.javac.code.Symbol$ParamSymbol.getSimpleName: LowPerformance took 24088 ms.
com.sun.tools.javac.code.Symbol$ParamSymbol.getSimpleName: LowPerformance too...
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Compiler
7.4
All All
: P3 (vote)
: 8.0.1
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-30 09:55 UTC by Exceptions Reporter
Modified: 2014-04-08 06:09 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (31.42 KB, application/nps)
2014-03-30 09:55 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2014-03-30 09:55:17 UTC
This bug was originally marked as duplicate of bug 187919, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.4 (Build 201310111528)
VM: Java HotSpot(TM) Client VM, 24.45-b08, Java(TM) SE Runtime Environment, 1.7.0_45-b18
OS: Windows 8

User Comments:
GUEST: ?????



Maximum slowness yet reported was 24088 ms, average is 24088
Comment 1 Exceptions Reporter 2014-03-30 09:55:19 UTC
Created attachment 146409 [details]
nps snapshot
Comment 2 Dusan Balek 2014-04-04 07:04:14 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/a97d29fd555f
Comment 3 Quality Engineering 2014-04-08 06:09:11 UTC
Integrated into 'main-silver', will be available in build *201404080419* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/a97d29fd555f
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #243379: com.sun.tools.javac.code.Symbol$ParamSymbol.getSimpleName: LowPerformance - fixed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo