Bug 242340 - org.netbeans.modules.progress.ui.RunOffEDTImpl.runOffEventThreadCustomDialogImpl: LowPerformance took 64795 ms.
org.netbeans.modules.progress.ui.RunOffEDTImpl.runOffEventThreadCustomDialogI...
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Project
7.4
All All
: P3 (vote)
: 8.2
Assigned To: Alexander Simon
issues@cnd
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks: 269857
  Show dependency treegraph
 
Reported: 2014-02-25 23:02 UTC by Exceptions Reporter
Modified: 2017-04-04 10:12 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (586.61 KB, application/nps)
2014-02-25 23:02 UTC, Exceptions Reporter
Details
proposed patch (11.07 KB, patch)
2015-09-07 15:27 UTC, Alexander Simon
Details | Diff
proposed patch, variant 2 (10.88 KB, patch)
2015-09-08 11:44 UTC, Alexander Simon
Details | Diff
refresh patch (12.85 KB, patch)
2016-07-21 16:11 UTC, Alexander Simon
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2014-02-25 23:02:34 UTC
Build: NetBeans IDE 7.4 (Build 201310111528)
VM: Java HotSpot(TM) 64-Bit Server VM, 24.51-b03, Java(TM) SE Runtime Environment, 1.7.0_51-b13
OS: Mac OS X

User Comments:
GUEST: <Please provide a description of the problem or the steps to reproduce>
I'm just compiling c++ code.

williambacchi: activating java fx and setting a wrong scenebuilder home



Maximum slowness yet reported was 64795 ms, average is 34415
Comment 1 Exceptions Reporter 2014-02-25 23:02:40 UTC
Created attachment 145585 [details]
nps snapshot
Comment 2 Jan Peska 2014-03-28 10:36:51 UTC
EDT calls org.netbeans.modules.project.ui.actions.ProjectAction.runSequentially() in a very long loop, further investigation needed.
Comment 3 Ondrej Vrabec 2015-03-06 12:18:06 UTC
a sequence:
at org.netbeans.modules.cnd.makeproject.MakeActionProvider.invokeAction(MakeActionProvider.java:349)
	at org.netbeans.modules.project.ui.actions.ProjectAction$2.run(ProjectAction.java:186)
	at org.openide.util.Mutex.doEvent(Mutex.java:1348)
	at org.openide.util.Mutex.writeAccess(Mutex.java:462)
	at org.netbeans.modules.project.ui.actions.ProjectAction.runSequentially(ProjectAction.java:183)
	at org.netbeans.modules.project.ui.actions.ProjectAction$2.run(ProjectAction.java:202)
seems to be repeated recursively many times - resulting in a deep stack and calling progressutils many times but in one AWT cycle -> no wonder the AWT gets stuck
Comment 4 Alexander Simon 2015-09-04 15:04:50 UTC
It seems user selected about 50 projects and invoke clean & build on selection.
Comment 5 Alexander Simon 2015-09-07 15:27:42 UTC
Created attachment 155944 [details]
proposed patch
Comment 6 Vladimir Kvashin 2015-09-08 05:57:28 UTC
(In reply to Alexander Simon from comment #5)
> Created attachment 155944 [details]
> proposed patch
I'll have a (more thorough) look. 
The bug seems worth fixing: lots of duplicate reports, quite a long EDT freezes in some of them. What confuses me a bit in the proposed solution is
- the overall complexity
- the fact that now if I invoke build for 50 projects UI won't freeze, but user will get these "Preparing to build" dialogues from time to time (quite unexpectedly)
Comment 7 Alexander Simon 2015-09-08 11:44:40 UTC
Created attachment 155959 [details]
proposed patch, variant 2
Comment 8 Alexander Simon 2016-07-21 16:11:10 UTC
Created attachment 161365 [details]
refresh patch
Comment 9 Alexander Simon 2016-07-22 08:09:50 UTC
fixed, change set:http://hg.netbeans.org/cnd-main/rev/403692127dfb
Comment 10 Quality Engineering 2016-07-23 01:52:10 UTC
Integrated into 'main-silver', will be available in build *201607230002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/403692127dfb
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #242340 org.netbeans.modules.progress.ui.RunOffEDTImpl.runOffEventThreadCustomDialogImpl: LowPerformance took 64795 ms.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo