Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 241476 - [80cat]Providing Custom annotation processor is not reflected in Editor or Run. Build works fine
[80cat]Providing Custom annotation processor is not reflected in Editor or Ru...
Status: RESOLVED WORKSFORME
Product: java
Classification: Unclassified
Component: Compiler
8.0
PC Mac OS X
: P3 (vote)
: 8.0.1
Assigned To: Dusan Balek
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-06 08:17 UTC by manikantannaren
Modified: 2014-07-18 16:56 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Projects' source code. (27.56 KB, application/force-download)
2014-02-06 08:17 UTC, manikantannaren
Details
Annprocessor project in classpath of DemoAnnProcessor project (59.67 KB, image/png)
2014-02-06 08:20 UTC, manikantannaren
Details
Annotation processor options (221.61 KB, image/png)
2014-02-06 08:20 UTC, manikantannaren
Details
Error badges. (162.37 KB, image/png)
2014-02-06 08:20 UTC, manikantannaren
Details

Note You need to log in before you can comment on or make changes to this bug.
Description manikantannaren 2014-02-06 08:17:20 UTC
Created attachment 144855 [details]
Projects' source code.

Tutorial to use
https://netbeans.org/kb/docs/java/annotations-custom.html

Created the projects
Built The second project which generates neccessary sources in the build/generated-sources folder.

Selected the DemoAnnProcessor project and chose Run from the Toolbar
got this error
run:
Exception in thread "main" java.lang.ExceptionInInitializerError
Caused by: java.lang.RuntimeException: Uncompilable source code - cannot find symbol
  symbol: class MainExtras
	at demoannprocessor.Main.<clinit>(Main.java:15)
Java Result: 1
BUILD SUCCESSFUL (total time: 3 seconds)


I also see error badges in the Project and Files view as well as the editor (screen shots).
Comment 1 manikantannaren 2014-02-06 08:20:16 UTC
Created attachment 144856 [details]
Annprocessor project in classpath of DemoAnnProcessor project
Comment 2 manikantannaren 2014-02-06 08:20:22 UTC
Created attachment 144857 [details]
Annotation processor options
Comment 3 manikantannaren 2014-02-06 08:20:25 UTC
Created attachment 144858 [details]
Error badges.
Comment 4 Dusan Balek 2014-07-18 16:56:39 UTC
Unfortunately, I cannot reproduce the problem in the current dev build. Everything works as expected.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo