Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 239387 - [80cat] JavaFX 7u45 Project: dist.jar broken reference prevents build
[80cat] JavaFX 7u45 Project: dist.jar broken reference prevents build
Status: VERIFIED FIXED
Product: javafx
Classification: Unclassified
Component: Project
8.0
PC Windows 8
: P3 (vote)
: TBD
Assigned To: Roman Svitanic
issues@javafx
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-11 21:11 UTC by Lou Dasaro
Modified: 2013-12-13 07:06 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Shows the error after generating a JavaFX 7u45 project (144.01 KB, image/jpeg)
2013-12-11 21:11 UTC, Lou Dasaro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lou Dasaro 2013-12-11 21:11:26 UTC
Created attachment 143079 [details]
Shows the error after generating a JavaFX 7u45 project

On a fresh install of NB 8/Dev, initially, JavaFX projects generated using JDK 7u45 won't build, and errors are displayed. If you change platform to JDK 8, it will build. Change back to 7u45, and now it builds. Subsequent new JavaFX projects on 7u45 then build correctly. See also related error.
Comment 1 Lou Dasaro 2013-12-11 21:40:54 UTC
Product Version: NetBeans IDE Dev (Build 201312090002)
Java: 1.8.0-ea; Java HotSpot(TM) Client VM 25.0-b60
Runtime: Java(TM) SE Runtime Environment 1.8.0-ea-b118
System: Windows 8 version 6.2 running on x86; Cp1252; en_US (nb)
Comment 2 Lou Dasaro 2013-12-12 00:28:37 UTC
This error does NOT occur when NetBeans is running on 7u45. It DOES occur when running on JDK 8.
Comment 3 Roman Svitanic 2013-12-12 11:29:29 UTC
I can't reproduce this on:

Product Version: NetBeans IDE Dev (Build 201312120002)
Java: 1.8.0-ea; Java HotSpot(TM) 64-Bit Server VM 25.0-b61
Runtime: Java(TM) SE Runtime Environment 1.8.0-ea-b119

Project created using 7u45, just after launch of IDE with clean userdir.
Please try once again with latest build.
Thanks!
Comment 4 Lou Dasaro 2013-12-13 07:05:52 UTC
I was able to repeatedly produce this before, but can't now. I tried this with:
Product Version: NetBeans IDE Dev (Build 201312120002)
Java: 1.8.0-ea; Java HotSpot(TM) 64-Bit Server VM 25.0-b61
Runtime: Java(TM) SE Runtime Environment 1.8.0-ea-b119

and now there is no bug. Tried with Build 201312090002 and still no bug.

I can only assume the JDK upgrade provided a fix.

Marking as Fixed and Verified, since I'm not going to waste time downgrading JDK to prove hypothesis, and generally don't believe in ghosts.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo