Bug 239172 - IllegalArgumentException: org.netbeans.modules.refactoring.java.callhierarchy.CallHierarchyTasks$InitializerElement@33456ed0
IllegalArgumentException: org.netbeans.modules.refactoring.java.callhierarchy...
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Compiler
7.4
All All
: P3 (vote)
: 8.0
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-05 19:39 UTC by emiddio
Modified: 2014-01-13 02:15 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.62 KB, text/plain)
2013-12-05 19:39 UTC, emiddio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description emiddio 2013-12-05 19:39:47 UTC
This bug was originally marked as duplicate of bug 234227, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.4 (Build 201310111528)
VM: Java HotSpot(TM) 64-Bit Server VM, 24.45-b08, Java(TM) SE Runtime Environment, 1.7.0_45-b18
OS: Windows 7

User Comments:
emiddio: reading code




Stacktrace: 
java.lang.IllegalArgumentException: org.netbeans.modules.refactoring.java.callhierarchy.CallHierarchyTasks$InitializerElement@33456ed0
   at com.sun.tools.javac.model.JavacElements.cast(JavacElements.java:652)
   at com.sun.tools.javac.model.JavacElements.getTreeAndTopLevel(JavacElements.java:585)
   at com.sun.tools.javac.model.JavacElements.getTreeAndTopLevel(JavacElements.java:614)
   at com.sun.tools.javac.api.JavacTrees.getPath(JavacTrees.java:329)
   at com.sun.tools.javac.api.JavacTrees.getPath(JavacTrees.java:321)
   at org.netbeans.modules.refactoring.java.callhierarchy.Call.createReference(Call.java:241)
Comment 1 emiddio 2013-12-05 19:39:48 UTC
Created attachment 142885 [details]
stacktrace
Comment 2 Dusan Balek 2014-01-09 16:23:52 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/333601476639
Comment 3 Quality Engineering 2014-01-13 02:15:36 UTC
Integrated into 'main-silver', will be available in build *201401130002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/333601476639
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #239172: IllegalArgumentException: org.netbeans.modules.refactoring.java.callhierarchy.CallHierarchyTasks$InitializerElement - fixed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo