Bug 236994 - NullPointerException at com.sun.tools.javac.comp.Check.checkMethod
NullPointerException at com.sun.tools.javac.comp.Check.checkMethod
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Compiler
7.4
All All
: P2 (vote)
: 8.0
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT
:
: 242030 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 16:25 UTC by janario
Modified: 2014-02-19 13:00 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.75 KB, text/plain)
2013-10-10 16:25 UTC, janario
Details
stacktrace (4.75 KB, text/plain)
2013-10-18 00:43 UTC, janario
Details
stacktrace (3.79 KB, text/plain)
2013-12-31 00:15 UTC, _ gtzabari
Details
stacktrace (3.52 KB, text/plain)
2014-02-07 02:04 UTC, michbarsinai
Details
stacktrace (3.79 KB, text/plain)
2014-02-07 03:34 UTC, _ tboudreau
Details
stacktrace (3.86 KB, text/plain)
2014-02-07 18:52 UTC, _ tboudreau
Details

Note You need to log in before you can comment on or make changes to this bug.
Description janario 2013-10-10 16:25:27 UTC
Build: NetBeans IDE Dev (Build 20131010-a2f7a8432e82)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.25-b01, Java(TM) SE Runtime Environment, 1.7.0_25-b15
OS: Linux

User Comments:
janario: Ctrl + p to see methods parameters

janario: coding




Stacktrace: 
java.lang.NullPointerException
   at com.sun.tools.javac.comp.Check.checkMethod(Check.java:898)
   at com.sun.tools.javac.comp.Attr.checkMethod(Attr.java:3999)
   at com.sun.tools.javac.comp.Attr.checkIdInternal(Attr.java:3771)
   at com.sun.tools.javac.comp.Attr.checkMethodIdInternal(Attr.java:3673)
   at com.sun.tools.javac.comp.Attr.checkMethodId(Attr.java:3646)
   at com.sun.tools.javac.comp.Attr.checkId(Attr.java:3634)
Comment 1 janario 2013-10-10 16:25:30 UTC
Created attachment 140983 [details]
stacktrace
Comment 2 janario 2013-10-18 00:43:28 UTC
Created attachment 141230 [details]
stacktrace

Ctrl +p to see methods parameters
Comment 3 _ gtzabari 2013-12-31 00:15:26 UTC
Created attachment 143529 [details]
stacktrace

Invoked code-complete.
Comment 4 Exceptions Reporter 2014-01-27 14:43:10 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=204493
Comment 5 michbarsinai 2014-02-07 02:04:29 UTC
Created attachment 144889 [details]
stacktrace

Editing a java file.
Comment 6 _ tboudreau 2014-02-07 03:34:29 UTC
Created attachment 144891 [details]
stacktrace

Doing complicated things with generics and invoking parameter completion
Comment 7 _ tboudreau 2014-02-07 18:52:33 UTC
Created attachment 144919 [details]
stacktrace

Invoke parameter completion on some half-written code:

ServerControl control = new Signalizer<ServerControl>()

press ctrl-p inside the ()'s
Comment 8 Exceptions Reporter 2014-02-07 18:52:39 UTC
This bug already has 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=204493
Comment 10 Quality Engineering 2014-02-19 02:47:23 UTC
Integrated into 'main-silver', will be available in build *201402190001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/2e2ce9c3db99
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #236994: NullPointerException at com.sun.tools.javac.comp.Check.checkMethod - fixed.
Comment 11 Dusan Balek 2014-02-19 13:00:34 UTC
*** Bug 242030 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo