Bug 23673 - I18N - mnemonic key doesn't work with translated.
I18N - mnemonic key doesn't work with translated.
Status: CLOSED WORKSFORME
Product: nblocalization
Classification: Unclassified
Component: Code
3.x
All All
: P2 (vote)
: TBD
Assigned To: Masafumi Matsuda
issues@java
: A11Y, I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-17 12:03 UTC by Masafumi Matsuda
Modified: 2002-12-23 16:35 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
snap shot (28.97 KB, image/gif)
2002-05-17 12:04 UTC, Masafumi Matsuda
Details
snap shot (13.28 KB, image/gif)
2002-05-17 12:05 UTC, Masafumi Matsuda
Details
snap shot (25.18 KB, image/gif)
2002-05-17 12:06 UTC, Masafumi Matsuda
Details
snap shot (35.28 KB, image/gif)
2002-05-20 03:21 UTC, Masafumi Matsuda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Masafumi Matsuda 2002-05-17 12:03:09 UTC
Please see attched image file. 
Mnemonic Keys which was mistaken on the Japanese
is attached.
To reproduce:
1.Highlight 
~/ffjuser40ee/sampledir/examples/ClockFrame.java
2.Tools -> Internationalize...
2-1.New... (filesys.gif)
2-2.Browse...(Select.gif)
2-3.Format...(Replace.gif)

The Mnemonic Keys of "Filesystem, Select, Replace
Code Format"

Would you check if the first character is not used
as mnemonic key?
By localization, the first character becomes
no-ascii character. As a
result, the mnemonic key doesn't work by
localization. To fix this
problem, we need to set two resource bundle
messages, one is for 
caption, another is for mnemonic.
  Example=TestString
  Example_Mnemonic=T

And we should use like this:
myButton.setText(myBundle.getString("Example"));
myButton.setMnemonic(myBundle.getString("Example_Mnemonic").charAt(0).

The following line does not work with localized
version, because the
first character is not an alphanumeric because
it's replaced to
multi-byte Japanese character.

OS:Solaris 5.9  
Orion Build:orion_ml_020507  fcc Build:20.4
JDK:JDK1.4.0
locale:ja
Comment 1 Masafumi Matsuda 2002-05-17 12:04:13 UTC
Created attachment 5805 [details]
snap shot
Comment 2 Masafumi Matsuda 2002-05-17 12:05:25 UTC
Created attachment 5806 [details]
snap shot
Comment 3 Masafumi Matsuda 2002-05-17 12:06:28 UTC
Created attachment 5807 [details]
snap shot
Comment 4 Masafumi Matsuda 2002-05-17 12:07:42 UTC
I added the keyword "A11Y" for the bug.
But I could not add the interest list for the bug.
(michele.budris@sun.com)
Comment 5 Masafumi Matsuda 2002-05-20 03:20:23 UTC
I found the same issue of Internationalization Wizard step3.
The Mnemonic Key of "Source"
Comment 6 Masafumi Matsuda 2002-05-20 03:21:43 UTC
Created attachment 5844 [details]
snap shot
Comment 7 _ pkuzel 2002-05-29 10:56:26 UTC
The first two screen shots must be fixed in bundles by using '&' for
tagging mnemonics. It cannot be fixed in code.

The third case is bug in HelpStringCustomEditor I will fix it.

The fourth case is bug in HardStringWizardPanel I will fix it.
Comment 8 _ pkuzel 2002-05-29 13:07:58 UTC
3) and 4) fixed.
1) and 2) must be fixed in translatedfiles
Comment 9 Marek Grummich 2002-07-22 11:41:42 UTC
Set target milestone to TBD
Comment 10 Ken Frank 2002-10-12 19:56:07 UTC
moving to p2 since a11y issue whereby mnemonic key does not
work at all in localized S1S product so needs to be fixed in nb4.
ken.frank@sun.com
Comment 11 hiroshiy 2002-11-15 08:41:17 UTC
Hello, 

I found that, this issue is no longer re-appeared by suitable
translation. Therefore, I agree with current specs.

But, this may be re-appeared in l10n works into other language, 
in nearly future.

And I hope that, all developers put "&" which shows mnemonic
in the string, even if mnemonic is an initial character of the string.
Then, all translators can understand that exists of mnemonic.

Thank you - Hiroshi.
Comment 12 hiroshiy 2002-11-15 08:41:42 UTC
closed.
Comment 13 hiroshiy 2002-11-19 06:00:09 UTC
And I've verified, '&' sign was inserted suitably in 
"Bundle.properies".
Therefore, this issue will never re-appear.
Thank you all !!
Hiroshi.
Comment 14 Jesse Glick 2002-12-23 16:35:47 UTC
Consistent use of the I18N keyword.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo