Bug 236145 - Deadlock while deleting XML file
Deadlock while deleting XML file
Status: RESOLVED DUPLICATE of bug 237545
Product: platform
Classification: Unclassified
Component: Explorer
7.4
PC Mac OS X
: P3 (vote)
: 8.0
Assigned To: Jan Peska
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 13:21 UTC by Tomas Zezula
Modified: 2013-12-19 13:55 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Threads Dump (23.08 KB, text/plain)
2013-09-19 13:21 UTC, Tomas Zezula
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Zezula 2013-09-19 13:21:54 UTC
Created attachment 140249 [details]
Threads Dump

See attached threads dump.

AWT: holds ExplorerManager$Listener and tries to acquire Children mutex (shared).
Module-Actions: hods Children mutex (exclusive) calls ExplorerManager$Listener.nodeDestroyed tying to obtain lock.

Both ExplorerManager$Listener and org.openide.nodes.Node are wrong. They are calling untrusted code under lock.
Comment 1 Tomas Zezula 2013-09-19 13:28:30 UTC
Possible solutions:
1) org.openide.explorer.ExplorerManager$Listener.nodeDestroyed() - lock free or reorder locks (take CH.mutex (exclusive) before obtaining the monitor).

2) Changing the org.openide.nodes.Node.fireNodeDestroyed() not to fire under lock may be dangerous, so the ExplorerManager$Listener.nodeDestroyed can do reschedule.

1st seems safer to me.
Comment 2 Ondrej Vrabec 2013-12-19 13:55:44 UTC
already fixed in #237545 (sol. #1 chosen)

*** This bug has been marked as a duplicate of bug 237545 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo