Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 235998 - org.netbeans.modules.java.navigation.ClassMemberPanelUI: java.lang.IllegalStateException: This must happen in the event thread!
org.netbeans.modules.java.navigation.ClassMemberPanelUI: java.lang.IllegalSta...
Status: RESOLVED DUPLICATE of bug 231104
Product: platform
Classification: Unclassified
Component: Actions
7.4
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Jan Peska
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-15 21:25 UTC by markiewb
Modified: 2015-03-06 12:36 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (100.92 KB, text/plain)
2013-09-15 21:25 UTC, markiewb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description markiewb 2013-09-15 21:25:34 UTC
Created attachment 140107 [details]
IDE log

java.lang.IllegalStateException: This must happen in the event thread!
	at org.openide.awt.Actions$Bridge.propertyChange(Actions.java:929)
	at org.openide.util.WeakListenerImpl$PropertyChange.propertyChange(WeakListenerImpl.java:196)
	at java.beans.PropertyChangeSupport.fire(PropertyChangeSupport.java:335)
	at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:327)
	at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:263)
	at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:303)
	at org.openide.util.actions.NodeAction$DelegateAction.resultChanged(NodeAction.java:616)
	at sun.reflect.GeneratedMethodAccessor53.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.openide.util.WeakListenerImpl$ProxyListener.invoke(WeakListenerImpl.java:458)
	at com.sun.proxy.$Proxy6.resultChanged(Unknown Source)
	at org.openide.util.lookup.AbstractLookup$NotifyListeners.run(AbstractLookup.java:542)
	at org.openide.util.lookup.AbstractLookup.notifyIn(AbstractLookup.java:314)
	at org.openide.util.lookup.AbstractLookup.addPairImpl(AbstractLookup.java:256)
	at org.openide.util.lookup.AbstractLookup.addPair(AbstractLookup.java:223)
	at org.openide.util.lookup.AbstractLookup$Content.addPair(AbstractLookup.java:1278)
	at org.openide.util.lookup.InstanceContent.add(InstanceContent.java:90)
	at org.netbeans.modules.java.navigation.ClassMemberPanelUI$7.run(ClassMemberPanelUI.java:774)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1432)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2042)

Product Version: NetBeans IDE 7.4 RC1 (Build 201309112301)
Java: 1.7.0_40; Java HotSpot(TM) 64-Bit Server VM 24.0-b56
Runtime: Java(TM) SE Runtime Environment 1.7.0_40-b43
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
Comment 1 Tomas Zezula 2013-09-16 10:36:53 UTC
The org.openide.util.actions.NodeAction$DelegateAction.resultChanged should not expect that changes from Lookup come in EDT, it's not guaranteed. In fact setting the lookup may be expensive operation which should not be done in EDT, see issue #223978, there are reports where setting the instance content took 45s.
Comment 2 Ondrej Vrabec 2015-03-06 12:36:06 UTC

*** This bug has been marked as a duplicate of bug 231104 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo