Bug 235463 - ArrayIndexOutOfBoundsException: 17
ArrayIndexOutOfBoundsException: 17
Status: VERIFIED FIXED
Product: connecteddeveloper
Classification: Unclassified
Component: Issuetracking Framework
7.4
All All
: P1 (vote)
: 7.4
Assigned To: Tomas Stupka
issues@connecteddeveloper
EXCEPTIONS_REPORT
: 74_HR_FIX
: 235670 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 16:07 UTC by Tomas Stupka
Modified: 2013-09-11 10:16 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.66 KB, text/plain)
2013-09-03 16:07 UTC, Tomas Stupka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Stupka 2013-09-03 16:07:51 UTC
Build: NetBeans IDE Dev (Build 20130903-e3e78bda552b)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.7-b01, Java(TM) SE Runtime Environment, 1.7.0_17-b02
OS: Mac OS X

User Comments:
tstupka: added a column to the issue table




Stacktrace: 
java.lang.ArrayIndexOutOfBoundsException: 17
   at org.netbeans.modules.bugtracking.issuetable.IssueTable.getPersistedColumnValues(IssueTable.java:706)
   at org.netbeans.modules.bugtracking.issuetable.IssueTable.access$700(IssueTable.java:108)
   at org.netbeans.modules.bugtracking.issuetable.IssueTable$7.run(IssueTable.java:581)
   at org.netbeans.modules.bugtracking.issuetable.IssueTable.setDefaultColumnSizes(IssueTable.java:645)
   at org.netbeans.modules.bugtracking.issuetable.IssueTable.ancestorAdded(IssueTable.java:663)
   at javax.swing.AncestorNotifier.fireAncestorAdded(AncestorNotifier.java:85)
Comment 1 Tomas Stupka 2013-09-03 16:07:54 UTC
Created attachment 139622 [details]
stacktrace
Comment 2 Tomas Stupka 2013-09-03 16:14:12 UTC
introduced by core-main #cfec8c6fef38

simplefix
Comment 3 Tomas Stupka 2013-09-03 16:19:46 UTC
happens almost every time the showed columns are changed -> highly visible and annoying

- open a query (e.g. ctx menu on query node in tasks dashboard)
- click the change columns button in the right upper corner of the table
- add a column and confirm
- if the exception did not appear yet - try to close and reopen the query again
Comment 4 Tomas Stupka 2013-09-03 16:45:18 UTC
fixed in core-main #36aa81b76ce1
Comment 5 Ondrej Vrabec 2013-09-04 11:16:22 UTC
the fix looks good
Comment 6 Tomas Stupka 2013-09-09 16:04:50 UTC
*** Bug 235670 has been marked as a duplicate of this bug. ***
Comment 7 Martin Kanak 2013-09-10 11:26:05 UTC
It seems to be fixed, no exception appears

Product Version: NetBeans IDE Dev (Build 201309090001)
Java: 1.7.0_40; Java HotSpot(TM) 64-Bit Server VM 24.0-b55
Runtime: Java(TM) SE Runtime Environment 1.7.0_40-b39
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
Comment 8 Tomas Stupka 2013-09-11 10:16:24 UTC
fixed in release74 #af267509a2ab


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo