Bug 234954 - StackOverflowError at org.openide.nodes.ChildrenArray.getChildren
StackOverflowError at org.openide.nodes.ChildrenArray.getChildren
Status: NEW
Product: platform
Classification: Unclassified
Component: Nodes
7.4
All All
: P3 (vote)
: TBD
Assigned To: Jan Peska
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-24 23:34 UTC by markiewb
Modified: 2013-08-24 23:34 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (15.05 KB, text/plain)
2013-08-24 23:34 UTC, markiewb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description markiewb 2013-08-24 23:34:19 UTC
This issue was reported manually by markiewb.
It already has 1 duplicates 


Build: NetBeans IDE Dev (Build 201205090400)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.5-b03, Java(TM) SE Runtime Environment, 1.6.0_30-b12
OS: Windows 7

User Comments:
markiewb: Menu Window -> Reset




Stacktrace: 
java.lang.IllegalStateException: Cannot initialize 0th child of node org.netbeans.core.ide.ServicesTab$ServicesNode@315e0969[Name=, displayName=]; it already belongs to node org.netbeans.core.ide.ServicesTab$ServicesNode@3d2c689f[Name=, displayName=] (did you forgot to use cloneNode?)
Children of new node: null
Children of old node: null
   at org.openide.nodes.Node.assignTo(Node.java:354)
   at org.openide.nodes.EntrySupportDefault.justComputeNodes(EntrySupportDefault.java:205)
   at org.openide.nodes.ChildrenArray.nodes(ChildrenArray.java:88)
   at org.openide.nodes.EntrySupportDefault.getNodes(EntrySupportDefault.java:123)
   at org.openide.nodes.EntrySupportDefault.getNodes(EntrySupportDefault.java:165)
   at org.openide.nodes.Children.getNodes(Children.java:469)
Comment 1 markiewb 2013-08-24 23:34:21 UTC
Created attachment 139188 [details]
stacktrace


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo